problem after demultiplexing code

I am stuck at a point
I run this command
time qiime deblur denoise-16S
--i-demultiplexed-seqs demux-filtered.qza
--p-trim-length 200
--o-representative-sequences rep-seqs-deblur.qza
--o-table table-deblur.qza
--p-sample-stats
--o-stats deblur-stats.qza

and I get table-deblur.qza, rep-seqs-deblur.qza and deblur-stats.qza

however, when I run the next command
time qiime feature-table tabulate-seqs
--i-data rep-seqs-deblur.qza
--o-visualization rep-seqs.qzv

I get this message
Plugin error from feature-table:

No values provided.

Debug info has been saved to /tmp/qiime2-q2cli-err-0v7d9ssk.log,

what should I do to solve this issue now? I am also attaching a piture of it

Hello and welcome back to the forum!
What is the length of your reads after demux and primer removal? If they are shorter than

--p-trim-length 200

then it is possible that deblur discarded all of them. In that case, you need to set a lower value for trimming or disable it to keep the reads.

1 Like

I tried, 80,90, 100, even 0. same error again and again , I have selected length from the visualization of demux.qzv file, visualized at the start, I am sending you and image of that as well, please guide me, I will really be thankful

Hi @sadaffaheem,
That's looks strange for me. It should work as it is and you tried different trimming values.
Could you share with us the content of the log file from the error (/tmp/qiime2-q2cli-err-0v7d9ssk.log), or rerun it in the verbose mode?

2 Likes

I will check but I really do not know where this file goes, I am sorry, but I will try to sort out soon

On Ubuntu, you can open it by runing:

gedit /tmp/qiime2-q2cli-err-0v7d9ssk.log

Or replace gedit with any installed text editor.

Another way is to add --verbose flag to the command, so everything will be printed in the terminal.

In addition, could you also share deblur outputs?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.