plugin errors with cutadapt

Hello,
I am using QIIME 2-2021.11 installed on Virtualbox, and I am having problems demultiplexing my sequence file. I have successfully imported the fastq.gz file and my metadata file. I have executed the cutadapt plugin with the following command:

$ qiime cutadapt demux-single
--i-seqs multiplexed-seqs.qza
--m-barcodes-file mymetadata.txt
--m-barcodes-column Barcode
--p-error-rate 0
--o-per-sample-sequences demultiplexed-seqs.qza
--o-untrimmed-sequences untrimmed.qza
--verbose

I get an error message with a lengthy and confusing description:

Traceback (most recent call last):
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/q2cli/commands.py", line 339, in __call__
    results = action(**arguments)
  File "<decorator-gen-408>", line 2, in demux_single
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/qiime2/sdk/action.py", line 245, in bound_callable
    outputs = self._callable_executor_(scope, callable_args,
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/qiime2/sdk/action.py", line 418, in _callable_executor_
    artifact = qiime2.sdk.Artifact._from_view(
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/qiime2/sdk/result.py", line 305, in _from_view
    result = transformation(view, validate_level)
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/qiime2/core/transform.py", line 68, in transformation
    self.validate(view, level=validate_level)
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/qiime2/core/transform.py", line 143, in validate
    view.validate(level)
  File "/home/qiime2/miniconda/envs/qiime2-2021.11/lib/python3.8/site-packages/qiime2/plugin/model/directory_format.py", line 179, in validate
    raise ValidationError("Unrecognized file (%s) for %s."
qiime2.core.exceptions.ValidationError: Unrecognized file (/tmp/q2-CasavaOneEightSingleLanePerSampleDirFmt-n3tea9x_/M_FIU.1.fastq.gz) for CasavaOneEightSingleLanePerSampleDirFmt.

Plugin error from cutadapt:

  Unrecognized file (/tmp/q2-CasavaOneEightSingleLanePerSampleDirFmt-n3tea9x_/M_FIU.1.fastq.gz) for CasavaOneEightSingleLanePerSampleDirFmt.

See above for debug info.

After getting this error the first time, I attempted to re-import the sequences.fastq.gz file (which becomes multiplexed-seqs.qza) and re-ran the cutadapt command, but I got the same error. I'm not sure how to make sense of this error message or how to fix it. Although the summary provided following the execution of this command appears to indicate that all of the samples to have been demultiplexed and the adapters trimmed, the output files were not created. Have the changes been made to the multiplexed-seqs.qza file or is it still in its original, multiplexed state? Just curious if I can rerun any downstream analysis on that file or whether I should re-import the original sequences.fastq.gz file before I attempt anything else.

Any help with this would be appreciated.

Andrew

I was able to solve this issue on my own. I had a space in one of the ID's in my metadata file that I had overlooked. I removed the space and re-ran the command and it worked.

Please consider this resolved, thanks.

Andrew

2 Likes