Plugin error from feature-classifier

Hello,I met a problem about feature-classifier.

The error information is :
Plugin error from feature-classifier:
The scikit-learn version (0.18.1) used to generate this artifact does not match the current version of scikit-learn installed (0.19.1). Please retrain your classifier for your current deployment to prevent data-corruption errors.
Debug info has been saved to /tmp/qiime2-q2cli-err-7epzgcn5.log

And the qiime2-q2cli-err-7epzgcn5.log is :
Traceback (most recent call last):
File “/home/lijing/miniconda3/envs/qiime2-2018.6/lib/python3.5/site-packages/q2cli/commands.py”, line 274, in call
results = action(**arguments)
File “”, line 2, in classify_sklearn
File “/home/lijing/miniconda3/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 226, in bound_callable
spec.view_type, recorder)
File “/home/lijing/miniconda3/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/result.py”, line 266, in _view
result = transformation(self._archiver.data_dir)
File “/home/lijing/miniconda3/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/core/transform.py”, line 70, in transformation
new_view = transformer(view)
File “/home/lijing/miniconda3/envs/qiime2-2018.6/lib/python3.5/site-packages/q2_feature_classifier/_taxonomic_classifier.py”, line 64, in _1
% (sklearn_version, sklearn.version))
ValueError: The scikit-learn version (0.18.1) used to generate this artifact does not match the current version of scikit-learn installed (0.19.1). Please retrain your classifier for your current deployment to prevent data-corruption errors.

I tried every method found in QIIME2 forum , but it coudn’t fix the problem. Can up please help me?

Hi @Wang,

You need to either download the latest pre-trained classifiers, or retrain your classifier for your current deployment. That should fix this issue!

I hope that helps!

1 Like

Thank you! I tried the first method, I download it by conda install --override-channels -c defaults scikit-learn=0.19.1,but it didn’t work. Maybe I think the second advice is right. But I don’t know how to do it, because I didn’t find command to change it. Could you help me?

No, you don’t need to up/downgrade scikit-learn… that will not work since other dependencies probably require later versions of scikit-learn that 0.18.1.

You can just download the latest pre-trained classifiers here. Looks like those were trained with the same scikit-learn version you have installed.

Or, if you are using a custom trained classifier, you just need to retrain in your current environment.

Good luck!

1 Like

Thank you very much! You solved the problem. The reason is that I got it wrong. I thought scikit-learn is classifier, but it didn’t. The https://data.qiime2.org/2018.8/common/gg-13-8-99-nb-classifier.qza is true classifier. I choose a new classifier, the problem was fixed. Thank you again, you not only help solved the problem, but also help understand which is classifier.
Thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.