Plugin error from feature classifier [2022.8]

Hello everybody,
I´m a new qiime2 user and low-experienced bioinformatician so (I hope) this question may be easy to solve. When I run ' qiime feature-classifier classify-sklearn ' command, it doesn´t work. This is the exact message:
Plugin error from feature-classifier:
[Errno 2] No such file or directory: '/tmp/qiime2/vmunoz/data/2bbe61fa-7f78-4913-a6a7-b42e6fff2279/provenance'
Debug info has been saved to /tmp/qiime2-q2cli-err-8_beyezv.log

When i open this log file, it content is:

Traceback (most recent call last):
File "/opt/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/q2cli/", line 339, in call
results = action(**arguments)
File "", line 2, in classify_sklearn
File "/opt/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/sdk/", line 210, in bound_callable
provenance.add_input(name, artifact)
File "/opt/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/core/archive/", line 425, in add_input
self.inputs[name] = self.add_ancestor(input)
File "/opt/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/qiime2/core/archive/", line 167, in add_ancestor
File "/opt/anaconda3/envs/qiime2-2022.8/lib/python3.8/", line 555, in copytree
with os.scandir(src) as itr:
FileNotFoundError: [Errno 2] No such file or directory: '/tmp/qiime2/vmunoz/data/2bbe61fa-7f78-4913-a6a7-b42e6fff2279/provenance'

I have seen some simmilar problems in the forum but none of them are reported for my qiime2 version (2022.8 installed from conda in my organization´s minicluster). In this thread I read obout the possibility of a agressive /tmp cleaning by my computer admin, but I dont really know if this is the real problem.

Thank you for your time,

1 Like

Hello Vimh,

Welcome to the forums! :qiime2:

Thank you for posting your full error. The missing path is an important clue:

If an input file was missing, it would look like this
No such file or directory: '/home/vmunoz/your-input-file.qza'

The fact that the missing file is in /tmp leads to this conclusion:

You can set /tmp to a different location, or reach out to your cluster admins about their /tmp settings. They should be able to tell you how they have set up /tmp to work, and if this could be causing the problem we suspect.

Keep us posted!

Hello Collin,
Thank you very much for your speed in answering my question. I will ask my computer admin for help and if it get solved, I´ll let you know. Until then, I´ll try to do the analysis in a local computer.

I have just noticed that the folder "2bb61fa-7f78-4913-a6a7-b42e6fff2279" came from the Silva 138 99% OTUs full-length sequences pre-trained classifier. I tried to unzip the classifier in order to see what are in, and one of the resulting directories is 2bb6qfa..... Do you find it relevant? If this classifier were "broken", i suppose many people would have reported it.

Thank you again,

1 Like

If this classifier were "broken", i suppose many people would have reported it.

Yes, I would suspect that as well. But you never know!

The temp air still makes me think it's related to your HPC setup. While I was away, did you hear back from your HPC team about how they set up /tmp on their cluster?

Unfortunately no, they are so busy :frowning: I´ll try next week.

Just for trying, I run the command using the classifier trained with 515F/806R sequences and it worked perfectly. Since I have 18S sequences too, I took the "challenge" of training my own classifiers and they are also working well. I don´t know if it is a clue, but the only classifier that gives me the error message is Silva 138 99% OTUs full-length sequences

Thanks for your help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.