Plugin error from diversity rarefaction depth

Hello everyone!
when I try to run the rarefaction command i get a error message saying it cant insert the depth. What does that mean? I tried different depths including very low and high ones but its always the same message. Thanks for your help!

qiime diversity alpha-rarefaction
–i-table table_no_chloroplast.qza
–i-phylogeny rooted_tree.qza
–p-max-depth 10000
–m-metadata-file Metadata.txt
–o-visualization alpha_rarefaction.qzv

Plugin error from diversity:
cannot insert depth, already exists

Hey @Barbs,

That is very cryptic. I have no idea what it means either, could you rerun the command with --verbose or attach the debug log file that’s printed at the bottom of the error?

Thanks so much!

1 Like

qiime2-q2cli-err-cljna5kf.txt (1.6 KB)

Hi Ebolyen,

thanks for the reply an sorry for the cryptic info. Here is the log file. I hope that helps...

1 Like

Hi @Barbs!

No need to apologize, the cryptic error is entirely on us. We failed to tell the computer to not say silly things like “cannot insert depth, already exists”. It looks like this has something to do with our Pandas dependency when it’s re-labeling an index. I’ve opened an issue here to track this bug.

In the meanwhile, it looks like it’s trying to move a column which was called “depth” around and collided with itself somehow. I’m not certain if it has to do with the word itself, but if we’re lucky it’s only that.

  • Do you have a metadata column named “depth”?
  • If so, does changing your metadata column named “depth” to anything else like “DEPTH” fix the situation?

Thanks for your help in figuring this out!

Hey @ebolyen,

I indeed do have a metadata column named “depth” and changing the name solved the problem!!!

I would have never come up with that idea! Thanks for the great advice… Man its a good day today! :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.