Plugin error from demux when practicing ''Moving Pictures'' in Qiime2

I am a new user of Qiime2, and this is my first time to use and Qiime related bio-informatics. I tried to practice “Moving Pictures” tutorial in Qiime2. I installed Qiime2 using Virtualbox.

The starting was good:grinning:

(qiime2-2019.1) [email protected]:/media/sf_Qiime2/qiime2-moving-pictures-tutorial$ qiime tools import \
>   --type EMPSingleEndSequences \
>   --input-path emp-single-end-sequences \
>   --output-path emp-single-end-sequences.qza
Imported emp-single-end-sequences as EMPSingleEndDirFmt to emp-single-end-sequences.qza

Until here, when I runned the bellow commands, then there popped up errors.:sweat_smile:

(qiime2-2019.1) [email protected]:/media/sf_Qiime2/qiime2-moving-pictures-tutorial$ qiime demux emp-single \
>   --i-seqs emp-single-end-sequences.qza \
>   --m-barcodes-file sample-metadata.tsv \
>   --m-barcodes-column BarcodeSequence \
>   --o-per-sample-sequences demux.qza

The errors are as::hot_face:

Plugin error from demux:

  /tmp/qiime2-archive-qg65j891/426c5b49-3232-414a-8a0b-0192ac6e1a79/data/barcodes.fastq.gz is not a file.

Debug info has been saved to /tmp/qiime2-q2cli-err-0pxdpd0g.log

Could any one who know this can deliver a solution or pointing out the reason for the error.

Thanksssss

I tried many time of testing, such as reinstall Qiime2 using VirtualBox, and change the location of shared folder, but none of them worked. Please help…

Hey there @GrassK!


I just want to take a moment to point out the QIIME 2 Forum Code of Conduct, specifically: Code of Conduct - QIIME 2 Forum


Are you following the Moving Pictures Tutorial with the tutorial dataset, or with your own dataset?

So, looking at this error message:

barcodes.fastq.gz is not a file

it suggests something is wrong with your input data --- can you run the following commands and provide the results:

ls -lah emp-single-end-sequences/
zcat < emp-single-end-sequences/barcodes.fastq.gz | head

Thanks! :qiime2:

1 Like

Hi Matt,
I run the commands as your suggestons and got below results:

(qiime2-2019.1) [email protected]:/media/sf_Desktop$ ls -lah emp-single-end-sequences/

total 28M
drwxrwx— 1 root vboxsf 4.0K Mar 18 16:13 .
drwxrwx— 1 root vboxsf 4.0K Mar 18 16:21 …
-rwxrwx— 1 root vboxsf 3.7M Mar 15 14:59 barcodes.fastq.gz.gz
-rwxrwx— 1 root vboxsf 25M Mar 15 14:59 sequences.fastq.gz.gz

(qiime2-2019.1) [email protected]:/media/sf_Desktop$ zcat < emp-single-end-sequences/barcodes.fastq.gz | head

bash: emp-single-end-sequences/barcodes.fastq.gz: No such file or directory

Thanks…

Should close this request. My colleague helped to fix this issue. After reset the working directory: qiime2-2019.1) [email protected]:/media/sf_Desktop/qiime2-moving-pictures-tutorial$
Then following Moving Pictures, it worked.

I guess because I chose Desktop as shared folder, but not set a file for working.

Thanks…

1 Like

Hmm, I am not so sure that was the problem. Take a look at the ls results above: your filenames had an extra .gz extension at the end. I am not sure why they were able to imported in the first place, but I suspect this had something to do with it.

Glad to hear you are sorted out now. Keep on QIIMEing! :qiime2:

1 Like