plug in error from demux

I am running Qiime 2 on the server and I keep getting the following error

Plug in error from demux:

Cannot describe a DataFrame without columns
Debug infor has been saved to /tmp/qiime2-q2cli-err-znjbu4yc.log

How do i rectify this error?

Hey there @desiree757! We need a lot more info from you in order to be of assistance:

  • What version of QIIME 2 are you running?
  • What is the exact command you ran? Copy and paste please
  • What is the full error you saw? Copy and paste when run with the --verbose flag, or, attach the referenced error log from the error message.

Thanks! :qiime2:

The version of qiime 2 I am using is (qiime2-2019.1)

The command I ran was

qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path gartersnakeqiime2
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path de-demux-paired-end.qza

Then I got :Imported gartersnakeqiime2 as CasavaOneEightSingleLanePerSampleDirFmt to de-demux-paired-end.qza

Once I did that I ran this command: qiime demux summarize
–i-data de-demux-paired-end.qza
–o-visualization de-demux.qzv

Then I received this error message: Plugin error from demux:
Cannot describe a DataFrame without columns

Debug info has been saved to /tmp/qiime2-q2cli-err-cdcxe1p5.log

Thanks @desiree757 — can you please rerun the command with the --verbose flag, or attach the error log:


sorry I am new to using this verbiage , I thought I attached everything , do you want me to rerun the script?

Hi this is what I got!

Usage: qiime demux summarize [OPTIONS]
Try “qiime demux summarize --help” for help.

Error: Got unexpected extra arguments ( de-demux-paired-end.qza de-demux.qzv flag)

Oops, looks like you accidentally removed the flag --o-visualization from the command. Please go back to the original command and append the --verbose flag to the end of it, like this:

qiime demux summarize --i-data de-demux-paired-end.qza --o-visualization de-demux.qzv --verbose

Make sense?

Hi @thermokarst this is what I got back !

s/>", line 2, in summarize
File “/home/smith5mr/miniconda3/envs/qiime2-2019.1/lib/python3.6/site-packages/qiime2/sdk/”, line 231, in bound_callable
output_types, provenance)
File “/home/smith5mr/miniconda3/envs/qiime2-2019.1/lib/python3.6/site-packages/qiime2/sdk/”, line 427, in callable_executor
ret_val = self._callable(output_dir=temp_dir, **view_args)
File “/home/smith5mr/miniconda3/envs/qiime2-2019.1/lib/python3.6/site-packages/q2_demux/_summarize/”, line 165, in summarize
forward_stats = _compute_stats_of_df(forward_scores)
File “/home/smith5mr/miniconda3/envs/qiime2-2019.1/lib/python3.6/site-packages/q2_demux/_summarize/”, line 92, in _compute_stats_of_df
percentiles=[0.02, 0.09, 0.25, 0.5, 0.75, 0.91, 0.98])
File “/home/smith5mr/miniconda3/envs/qiime2-2019.1/lib/python3.6/site-packages/pandas/core/”, line 8500, in describe
raise ValueError(“Cannot describe a DataFrame without columns”)
ValueError: Cannot describe a DataFrame without columns

Plugin error from demux:

Cannot describe a DataFrame without columns

See above for debug info.

Please take a few moments to review the Forum’s code of conduct.

1 Like

Problem solved just reimported my fast q files and ran the script on the server!

1 Like

I imagine there was some kind of issue the first time you imported --- that error message seems to indicate that there was an "empty" list of things somewhere. Not sure if that was an empty sample with no sequences in it, or, if the list of samples was empty. If you still have the offending artifact around feel free to message me a download link to it, I would love to take a closer look!
:qiime2: :t_rex:

1 Like

@thermokarst thank you so much you guys are amazing and super speedy with helping!

1 Like

This is the error I'm getting when I attempt to run the following command

qiime demux summarize
--i-data cnn-paired-end-demux.qza
--o-visualization cnn-demux.qzv

any ideas on what is happening here?

garter.csv (3.8 KB)

I also attached my .csv and here is the previous command I used to import the data that worked succesfully

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path garter.csv
--output-path cnn-paired-end-demux.qza
--input-format PairedEndFastqManifestPhred33

This is a previously unreported error message - can you please share a download link to the file cnn-paired-end-demux.qza (okay to send in a direct message). Thanks! :qiime2:

I am having trouble finding the file on my MAC , how should I locate it. I searched in finder and it didn’t show up, but I know it is on the computer somewhere

Hmm, I don’t think we can help with that - do you have someone local to you that can help show you around on your computer? Maybe an IT department, or a colleague?

Actually, wait a minute, is it on your mac? I thought I saw some discussion yesterday that mentioned you were logging into a remote server. Either way, maybe you can get some help with this from someone more familiar with your computing environment?