Picrust2 not recognized

It looks like at some point that the qiime2-2020.6 environment was added to the beginning of your $PATH variable (as indicated by /home-1/[email protected]/miniconda3/envs/qiime2-2020.6/bin). This is supposed to happen when you activate the environment, but not when you're in your base conda environment.

Depending on your system you'll have a configuration file that has commands that are run every time you login (one of these most likely: .bashrc, .profile, or .bash_profile). If you check in these files was a line added so that the PATH variable is altered to point to the qiime2-2020.6 bin folder? If so then perhaps commenting out that line will solve these problems you're running into.



It looks like there was a line about the qiime2-2020.6 env in the .bashrc file, which I have now commented out:

#custom permissions -------
umask 007
umask g+w

# >>> conda initialize >>>
# !! Contents within this block are managed by 'conda init' !!
__conda_setup="$('/home-1/[email protected]/miniconda3/bin/conda' 'shell.bash' 'hook' 2> /dev/null)"
if [ $? -eq 0 ]; then
    eval "$__conda_setup"
    if [ -f "/home-1/[email protected]/miniconda3/etc/profile.d/conda.sh" ]; then
        . "/home-1/[email protected]/miniconda3/etc/profile.d/conda.sh"
        export PATH="/home-1/[email protected]/miniconda3/bin:$PATH"
unset __conda_setup
# <<< conda initialize <<<

#export PATH="/home-1/[email protected]/miniconda3/envs/qiime2-2020.6/bin:$PATH"

export TMPDIR=$HOME/scratch

However, if I then say conda activate qiime2-2021.2, I still get the same error message as above:


Is this after logging out and logging back in again? Otherwise I'm out of ideas, sorry!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.