Pick_closed_reference_otus.py: command not found?

I try to generate otu-table to use in PICRUSt following PICRUSt docs.
I got this message:
pick_closed_reference_otus.py: command not found

I am using qiime2-2018.4. May any help please. I am new in linux and qiime as well.

Good afternoon Eman,

pick_closed_reference_otus.py: command not found

That’s a script that’s part of qiime 1, but don’t worry, Qiime 2 can do closed-ref OTU picking too!

See this thread for more information about how to build a PiCRUSt compatible OTU table using Qiime 2. :qiime2:

Let us know if you have any questions.

Hi Colin,
Much thanks. I will go through the thread and let you know. Actually, I found another package in R Tax4Fun which uses SILVA (as I am using SILVA v132 in my project). So, I thought it is better to use the same classifier. I spend the entire morning trying to download Tax4Fun, with no hope. I tried using command line, then tried Rconsole. I got an error, need qiimer and biom packages. I did installed qiimer, but biom package is deprecated and now it is biomformat which is already installed in my Rstudio. Then, at the end I got an error that Tax4Fun is not available for Rstudio v3.4.4.
I sent an e.mail to one of Tax4Fun support team, and waiting for a reply.
I wonder if you have any suggestions, I would be thankful.

Hello Eman,

While I do most of my analysis of R, it can be tricky to set up. Let’s try to get this set up in Qiime 2.

Here is the plugin I recommend:
qiime vsearch cluster-features-closed-reference

So basically, you follow this tutorial, but once you get to
qiime deblur you don’t use that plugin, instead of you use
qiime vsearch cluster-features-closed-reference. You can extract the .biom file and use that as the input to picrust.

Thanks for asking this question. Someone should write a tutorial about this.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.