Only 2 levels in the taxa bar-plots

Hi,
Im getting only 2 levels in the taxa bar plots and even they are general bacteria and unclassified (only two).

Does anyone have any idea what the reason for this could be…?

Thank you very much!

Hey there @Naamah!

Have you run metadata tabulate on your taxonomy? If so, what do those results look like? I suspect this isn’t a problem with the barplots specifically, but rather the taxonomic assignment. If that is the case, have a look at this post and please answer the questions posed in that post here. Thanks!

1 Like

Hi and thank you for your reply!

I assume you are right. The taxonomy already give these results… (all the thousands features are of either bacteria or unassigned…)

I am using the qiimes normal gg classifier. The primers are for V2 and are on the reverse reads.
These are the commands I used in that part:

qiime feature-classifier classify-sklearn --i-classifier ~/Naamah/Qiime/gg-13-8-99-515-806-nb-classifier.qza --i-reads rep-seqs.qza --o-classification Semen_taxonomy_all.qza

qiime metadata tabulate --m-input-file Semen_taxonomy_all.qza --o-visualization Semen_taxonomy_all.qzv

Thank you very much, Naamah.

Hey @Naamah,

It looks like this is the problem, you’re using a classifier trained on the V4 region. You can use the full-length classifier instead to get around that problem (or even train your own for the V2 region specifically).

Thank you so much. Sounds absolutely right! I just dont know which of the links there is the full length classifier… its not clear…
Could you please refer me to the exact link for it.
Thanks!!

Here they are!

Silva 132 99% OTUs full-length sequences
Greengenes 13_8 99% OTUs full-length sequences

:slight_smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.