Not able to train classifer

I am struggling with classifier training but it’s not working for some reason. I am using macOS (big sur). There is no error, simply the job is killed

[1] 54127 killed qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads

after running the command

qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads ref_seqs.qza --i-reference-taxonomy silva_132_99_ref_taxonomy.qza --o-classifier trained_classifier.qza

I tried to use pre-trained classifiers but sklearn version I have is 0.24.2 and the newest trained classifer I can find os on 0.24.1. I tried installing the old version but it doesn’t help either. I am in a dire need to finish some analysis and looking forward to any quick help (please!).

when I add --versobe, I get the following message additionally

/Users/macair/opt/miniconda3/envs/qiime2-2020.2/lib/python3.6/site-packages/q2_feature_classifier/ UserWarning: The TaxonomicClassifier artifact that results from this method was trained using scikit-learn version 0.24.2. It cannot be used with other versions of scikit-learn. (While the classifier may complete successfully, the results will be unreliable.)


  • Version of QIIME 2: qiime2-2020.2
  • I have 80 gb of free hard disk space

An off-topic reply has been merged into an existing topic: Training classifier error: [1] 44206 killed

Please keep replies on-topic in the future.