No reads passed the filter after q2-itsxpress

its
(M.Amine) #1

Hello
I am implementing q2-itsxpress in the analysis of ITS sequences.

After running below code,
qiime itsxpress trim-pair-output-unmerged
–i-per-sample-sequences “$path_to_data/output_sp001/demux_sp001.qza”
–p-region ITS2 --p-taxa F --p-threads 2
–o-trimmed “$path_to_data/output_sp001/demux_sp001_trimmed.qza”

I got the following error message,

No reads passed the filter. trunc_len_f (0) or trunc_len_r (0) may be individually longer than read lengths, or trunc_len_f + trunc_len_r may be shorter than the length of the amplicon + 20 nucleotides (the length of the overlap). Alternatively, other arguments (such as max_ee or trunc_q) may be preventing reads from passing the filter.

I have tried to visualize the data using demux summarize on trimmed reads and failed with the following error message.

Plugin error from demux:
Cannot describe a DataFrame without columns
Debug info has been saved to /tmp/qiime2-q2cli-err-iku7o_p7.log

These are maybe two threads, but might be linked to the q2-itsxpress output file!
I used qiime2-2018.11
Is there different output formats from q2-itsxpress that I should specify or pass to dada2 and qiime demux summarize? I
Thank you for inputs.

0 Likes

(M.Amine) #2

I have solved this one by indicating the right primer set used for the ITS pcr-amplification, but still having trouble to make visual file of demux_trimmed.qza.

0 Likes

(Matthew Ryan Dillon) #3

ccing @Adam_Rivers :qiime2:

0 Likes

(system) closed #4

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

0 Likes