No merged sequence by dada2 after update to 2019.1

I use to do a tutorial with a subset of sequence with Qiime2 2018.6. However, when I tried to analyze the sequence again with Qiime2 2019.1, after running dada2, I only got 4 features instead of 1000ish. I checked the denoting-stats and found out that most of the sequences failed to merge. Here I attached the command I ran:
In 2018.6 I ran,
qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path sample_manifest_file.txt --output-path demux-paired-end_old.qza --source-format PairedEndFastqManifest33
qiime dada2 denoise-paired --i-demultiplexed-seqs demux-paired-end_old.qza --p-trim-left-f 20 --p-trim-left-r 22 --p-trunc-len-f 0 --p-trunc-len-r 0 --o-table table_old.qza --o-representative-sequences rep-seqs_old.qza --o-denoising-stats denoising-stats_old.qza
In 2019.1 I ran,
qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path sample_manifest_file_new.txt --output-path paired-end-demux.qza --input-format PairedEndFastqManifestPhred33
qiime dada2 denoise-paired --i-demultiplexed-seqs paired-end-demux.qza --p-trim-left-f 20 --p-trim-left-r 22 --p-trunc-len-f 0 --p-trunc-len-r 0 --o-table table.qza --o-representative-sequences rep-seqs.qza --o-denoising-stats denoising-stats.qza
Here I attached 2 denoising-stats qza file:
denoising-stats_old.qza (6.9 KB)
denoising-stats.qza (10.1 KB)
Could someone help with this? I really wonder why the same raw sequences will generate features with such a big difference between versions.

Thanks for attaching your denoising stats QZAs! I looked at the provenance, and it appears you are using two totally different inputs to the workflow (the old one used a manifest called sample_manifest_file.txt, while the new one used a manifest called sample_manifest_file_new.txt). Was there any change between the two imports? Why did you re-import? The runtimes on the import command are pretty different — was there a significant change in the number of samples imported?

1 Like

Thank you for your reply! The input is the same, I just change the absolute path to $PWD/pathtosequences. I attached the 2 manifest file here. The qiime 2019.1 couldn't not use the demux-paired-end-old.qza because of the version problem. It gave me error. So I have to re-import it. There isn't a change in the number of samples imported. I wanted to upload the qza for demultiplexed sequences however it reaches the limit of the upload.
sample_manifest_file.txt (11.4 KB)
sample_manifest_file_new.txt (7.2 KB)

I’m not sure what you mean — QIIME 2 is backwards compatible — all old Artifacts are readable in newer versions of QIIME 2. Can you please provide the command you ran and the error message you saw?

Do you still have the original Artifact around? Can you please run demux summarize on the Artifacts with UUIDs 3eac2479-14a5-45c9-b4e3-08d718a0d003 (old) and 1fa5a595-872f-4f12-9c64-57e3ca829d62 (new) and share them here?