Need help installation onMacOS Sierra

HI,
I am trying to install the qiime2 on the MacOS HighSierra.
I keep getting the following error message when doing"
curl https://data.qiime2.org/distro/core/qiime2-2018.4-py35-osx-conda.yml "

curl: (77) error setting certificate verify locations:
** CAfile: /Users/nutrition/anaconda2/ssl/cacert.pem**
** CApath: none**

Could you help?
Thank you!

i check my folder and do not see the anaconda2 and only have anaconda. Not sure if this is the reason.34%20PM

Hi @JP2018,

Sorry for the delay,

It looks like your system has a couple of virtual environment happening at once. What does:

which curl

say? It looks like that is coming from anaconda.

Also, are you currently in a MacQIIME environment? I would exit from that when using QIIME 2 or more standard conda workflows.

Thank you for your response!
I exit MACQIIME, and run it. Still showing the same error message.
Here is what I got:

Last login: Fri Oct 19 14:24:10 on console

nutritions-MacBook-Air:~ nutrition$ which curl

/Users/nutrition/anaconda/bin/curl

nutritions-MacBook-Air:~ nutrition$ curl https://data.qiime2.org/distro/core/qiime2-2017.12-py35-osx-conda.yml

curl: (77) error setting certificate verify locations:

CAfile: /Users/nutrition/anaconda2/ssl/cacert.pem

CApath: none

nutritions-MacBook-Air:~ nutrition$

Thanks @JP2018,

It looks like your environment is a bit misconfigured, so to figure out exactly how to fix it, let’s run these commands:

echo $PATH
echo $PYTHONPATH
conda info
conda env list
tail ~/.bash_profile

And then if you were to enter MacQIIME, what does this say:

which python

(I just need to know where it is keeping the MacQIIME Anaconda so we don’t erase that on accident!)


That should let me know what we can/can’t reinstall (which should more or less fix the issue).

Here are what I got . Thank you!

  1. echo $PATH
    /Users/nutrition/miniconda2/bin:/Users/nutrition/anaconda2/bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/Users/nutrition/anaconda2/bin:/Users/nutrition/anaconda/bin:/Library/Frameworks/Python.framework/Versions/3.5/bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/ncbi/blast/bin:/opt/X11/bin

  2. echo $PYTHONPATH
    /usr/local/lib/python2.7/site-packages:

  3. conda info
    -bash: /Users/nutrition/anaconda/bin/conda: /Users/nutrition/anaconda2/bin/python: bad interpreter: No such file or directory

  4. conda env list
    -bash: /Users/nutrition/anaconda/bin/conda: /Users/nutrition/anaconda2/bin/python: bad interpreter: No such file or directory

  5. tail ~/.bash_profile

# Setting PATH for Python 2.7
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/2.7/bin:${PATH}"
export PATH

# added by Anaconda2 4.1.1 installer
export PATH="/Users/nutrition/anaconda2/bin:$PATH"

# added by Miniconda2 installer
export PATH="/Users/nutrition/miniconda2/bin:$PATH"
  1. after enter MAcQIIME
    which python
    /macqiime/anaconda/bin/python
1 Like

Thanks @JP2018!

Alrighty, it’s looking like we have a couple of conda installs which is messing everything up. Also, it looks like your macqiime is nicely tucked away, so we shouldn’t need to worry about hurting it.

That is a lot of Pythons! It looks like these are all set in your .bash_profile, so we’ll edit that in a minute.

Do you have a particular reason you would need this to be set? I HIGHLY recommend not setting $PYTHONPATH as it is really hard to keep track of and causes a mess. Based on some of your other directories in $PATH we should be able to remove this.


Editing your .bash_profile

If you have a text-editor you can use that, otherwise we’ll just go with nano (nano ~/.bash_profile).

We need to removed everything that says something like:

# added by Anaconda/Miniconda/Python installer
export PATH=...

There will likely also be a line that sets your PYTHONPATH, remove that as well (or at least comment it out with a # character in front).

Once you’ve done that, open a new terminal and type:

echo $PATH

and post that here again. Ideally we should see something like:

/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/ncbi/blast/bin:/opt/X11/bin

which would be correct.


Assuming all of that goes well, you should also remove your $HOME/anaconda directory and then re-install miniconda (this will edit your bash_profile again, but that’s ok this time).

Finally you should be able to install QIIME 2 from the normal conda instructions.

Let me know if that makes sense, or if you need help!

Sorry for the late response! Someone from our IT helped me with the installation before. Have no idea what is $PYTHONPATH :slight_smile:
I tried to run "nano ~/.bash_profile" in terminal, below is what I have. Could you confirm that if I can remove the yellow highlights?

Thank you very much!

Yep, that looks right to me. Keep us posted! :t_rex:

here is what I got after editing the nano edit
43%20PM

Then I run "echo $PATH, and get the following ,43%20PM

Can I continue?
Thank you!