Missing one or more files when importing into Qiime2

Hello everyone. I am a new user here and I am having a lot of trouble importing files into Qiime 2 even after following the directions from the importing tutorial. I am using qiime2-2020.2 via VirtualBox, and below is my code:
qiimetools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path '/tmp/VirtualBox Dropped Files/2020-05-23T16:42:04.085789000Z/all_raw_data' all_raw_data/ --input-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

The terminal then spits out:
There was a problem importing /tmp/VirtualBox Dropped Files/2020-05-23T16:42:04.085789000Z/all_raw_data:

Missing one or more files for CasavaOneEightSingleLanePerSampleDirFmt: '.+_.+_L[0-9][0-9][0-9]_R[12]_001\.fastq\.gz'

I've included screenshots of the folder my file is in and what the files look like. Thank you and I appreciate all of your help.

P.S. Is there a way to copy and paste between the VirtualBox Qiime2 terminal and your computer in general? It seems like I can't copy and paste the code from the terminal to here and have to manually copy it.

HI @Bill_Yen,

I think the error is complaining about the files not being named the way it is expecting for Casava format. I’m not sure what exactly the error is, it could be that the file names don’t end with .gz or something else with the multiple dashes in your sample names. It may be as easy as adding the .gz extension (since the files are already in GZ format), but not sure…probably the surest solution would be to use a manifest file import where there is no naming restrictions.

Sure, just follow the instructions in the VirutalBox installation docs, namely where it covers copy & pasting.


Got it, thanks for the help! I ended up enabling drag and drop through the same setting window as enabling copy/paste and dragging the file into the virtual machine to import it, which worked. Thanks so much for your help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.