missing id features as tip names in phylogeny

Dear All,
thanks in advance for your attention and help.
I merged my samples batch following the FMT tutorial and using a tex tool to make a new samples-metadata.tsv
I first run the qiime phylogeny align-to-tree-mafft-fasttree and everything worked well.
Then, I run the qiime diversity core-metrics-phylogenetic and I received the following error:

Plugin error from diversity:
All feature_ids must be present as tip names in phylogeny. feature_ids not corresponding to tip names (n=342): d64ae243450f88d63658c28c3a7ec5b (more features id)
Debug info has been saved to /scratch_local/slurm_job.4876860/qiime2-q2cli-err-20taa38n.log

May I lost some features in the merging process?
Can anyone understand how to overcome this issue and what does cause it?

Thanks, everybody!
Chiara

Ciao @chiara,

You should not have lost ant features after the merging.
Just to double-check few points, did you use the same denoising parameters for both runs?
Did you use the merged sequence file for the align-to-tree-mafft-fastree step?
Did you filter the table/sequences before the diversity analysis?

Cheers,
Luca

1 Like

Dear Luca,
thank you very much for your reply.
Following the FMT tutorial I merged the rep-seqs as follow:
qiime feature-table merge
–i-tables table-1.qza
–i-tables table-2.qza
–o-merged-table table.qza
qiime feature-table merge-seqs
–i-data rep-seqs-1.qza
–i-data rep-seqs-2.qza
–o-merged-data rep-seqs.qza

then I have used the output to make the phylogeny
qiime phylogeny align-to-tree-mafft-fasttree
–i-sequences rep-seqs.qza
–o-alignment aligned-rep-seqs.qza
–o-masked-alignment masked-aligned-rep-seqs.qza
–o-tree unrooted-tree.qza
–o-rooted-tree rooted-tree.qza

I did not filter the table neither the sequences.

Thank you very much,
Chiara

Dear @chiara
sound as a mystery to solve! :face_with_monocle:

First thing to double check, can you pass also the denoising command for both runs, please?

Do you have a log for the ‘qiime phylogeny align-to-tree-mafft-fastree’, to check that was actually completed successfully?

Cheers
Luca