Metadata formatting issue in QIIME2

I validated the metadata file in google sheet with Keemei…still it gives the error message (below)

  • Version of QIIME 2 you are running, and how it is installed: qiime2-2019.10, installed through conda

  • What is the exact command or commands you ran? qiime diversity adonis --i-distance-matrix braycurtis_qiime2/distance_matrix.qza --m-metadata-file metadata.txt --p-formula “Treatment” --o-visualization ADONIS_qiime2

  • What is the exact error message?
    Error: Detected invalid character in: “Treatment”
    Verify the correct quotes or dashes (ASCII) are being used.

The metadata in google sheet:

I opened the metadata file excel and retyped the column header. Still the same error. What am I doing wrong? Thank you.

HI @ehossain,
The problem seems to be coming from the quotes you are using. Can you try re-running with "Treatment" instead and let us know how that goes?


I copied the “Treatment” from your quote and it worked. Previously I was copy pasting from a text editor where I wrote the formula. Any clue what is the difference between the two quotation marks? Thank you.

1 Like

Hi! Not all editors are suitable for writing Qiime2 commands (some coding issues, I suppose). Maybe you should switch to other editor to write and keep the commands or use Jupyter Lab instead