meeting mistake when using vsearch join-pairs command

hi, I want to merge my pair-end 16s sequence using vsearch plugin in qiime2. I have imported the data successfully and check the read using qiime demux summarize command. After that, I using qiime vsearch join-pairs command to join my sequences. The command is like this:

qiime vsearch join-pairs
–i-demultiplexed-seqs liu_paired_end_demux.qza
–o-joined-sequences liu_joined_demux.qza

Then, I met this error message as following:

Plugin error from vsearch:

Command ‘[‘vsearch’, ‘–fastq_mergepairs’, ‘/var/folders/w7/bdg57j1x07ncyvkcm5w8tqhw0000gn/T/qiime2-archive-ynxvr7y1/7144f952-0264-498f-b766-3a50885291a5/data/SRR5723626_193_L001_R1_001.fastq.gz’, ‘–reverse’, ‘/var/folders/w7/bdg57j1x07ncyvkcm5w8tqhw0000gn/T/qiime2-archive-ynxvr7y1/7144f952-0264-498f-b766-3a50885291a5/data/SRR5723626_423_L001_R2_001.fastq.gz’, ‘–fastqout’, ‘/var/folders/w7/bdg57j1x07ncyvkcm5w8tqhw0000gn/T/q2-SingleLanePerSampleSingleEndFastqDirFmt-1da2fcf9/SRR5723626_180_L001_R1_001.fastq’, ‘–fastq_ascii’, ‘33’, ‘–fastq_minlen’, ‘1’, ‘–fastq_minovlen’, ‘10’, ‘–fastq_maxdiffs’, ‘10’, ‘–fastq_qmin’, ‘0’, ‘–fastq_qminout’, ‘0’, ‘–fastq_qmax’, ‘41’, ‘–fastq_qmaxout’, ‘41’, ‘–threads’, ‘1’]’ returned non-zero exit status 1.

Debug info has been saved to /var/folders/w7/bdg57j1x07ncyvkcm5w8tqhw0000gn/T/qiime2-q2cli-err-0spsl2kj.log.

my qiime2 and vsearch version is 2019.10 version.

Hello @siriusorignblack,

Welcome to the forums! :qiime2:

Let’s see if we can find some more log files that will give us clues about what’s going wrong. You can do this by rerunning this command and adding the --verbose flag, and also by looking at the Debug info that has been saved into that log file listed at the end of the script.

While we are looking for clues, what was the command you used to import data?

Colin

P.S.
:zap: :wolf: :black_heart:

Thank you for the answer. before reading your answer, I have found qiime validate could be employed to validate whether data are imported successfully. Then I met error reporting that one file was not imported successfully (I guess some mistakes have taken place). So I import my data again and everything goes ok.
the command I use to import data is:
qiime tools import \

–type ‘SampleData[PairedEndSequencesWithQuality]’ \

–input-format PairedEndFastqManifestPhred33V2 \

–input-path ./liu-manifest.tsv \

–output-path ./liu_paired_end_demux.qza

thanks again for the reply.
zhenyu

2 Likes