Manifest input error, Please help


(Marvin Yeung) #1

Dear all, I’ve read all other posts that has similar problems while importing with the manifest method yet mine is different so I’m creating a new thread, any help is appreciated.

I have fastq files that barcodes and primers are trimmed and seperated, e.g. 1 fastq file per sample, forward read. I tried importing it via the manifest sample and the error is as follow, tried both Phred33 and 64.

There was a problem importing /Users/myhyeung/Desktop/Files/Study/QIIME/Working Directory/se-64-manifest.csv:

/Users/myhyeung/Desktop/Files/Study/QIIME/Working Directory/se-64-manifest.csv is not a(n) SingleEndFastqManifestPhred64 file:

File referenced on line 2 could not be found (/Users/myhyeung/Desktop/Files/Study/QIIME/Working\ Directory/Y103.fastq).

I’m sure my manifest file is of correct format, as pasted here.

sample-id,absolute-filepath,direction
a1,/Users/myhyeung/Desktop/Files/Study/QIIME/Working\ Directory/Y103.fastq,forward

And Y103.fastq is in the path folder (same folder as the manifest file).
If anyone has experience or insight on such issue, any advice on what’s wrong? Any help is appreciated, many thanks.

2018.11. qiime2 was used via conda.


#2

Is it a stroke from a manifest file? Its strange in this part
Working\ Directory


(Matthew Ryan Dillon) #3

This error message says that QIIME 2 was unable to find a file located at /Users/myhyeung/Desktop/Files/Study/QIIME/Working\ Directory/Y103.fastq. Is there a typo in the filename? What happens when you run ls /Users/myhyeung/Desktop/Files/Study/QIIME/Working\ Directory/Y103.fastq?


(Marvin Yeung) #4

Many thanks guys! the problem was with the working\ directory, the folder was named “working directory” and seems like the default path naming from macos uses a \ for the space and its not compatible with qiime2, silly mistake my bad. Thanks again! @timanix @thermokarst