Low reads in Qiime2

Hi
I have some data. after I imported them and see the reads are too low while in Qiime 1 the reads were more much than this.
Is it make sense to have lower reads in qiime 2 in comparison with qiime 1? if not what kind of mistakes I made do you think? I used “Fastq manifest” formats to import my data.
thank you

Hi @mohsen_ej, we need quite a bit more information in order to help you. Can you please provide some concrete commands that you ran in QIIME 2, as well as example outputs that illustrate and clarify your question a bit? We also need to know the version of QIIME 2 you are using. Thanks!

QIIME 2 Core - 2020.8 (1598972704) this is the version I’m using.
I’ve got 12 meat samples, forward&reverse reads. they were demultiplexed already. the data has quality score as well as you can see in the picture.


I read the Importing data tutorial and found out I have to use Fastq manifest format.
so I created a manifest file and used this command :
qiime tools import **

–type ‘SampleData[PairedEndSequencesWithQuality]’ **

–input-path data-manifestfile **

–output-path paired-end-demux.qza **

–input-format PairedEndFastqManifestPhred33V2
then the result was this picture :


but the reads I get was less than the reads which got in qiime 1 by somebody else.
could you please let me know if I made a mistake or if it makes sense.
Thank you in advance.

Hi @mohsen_ej!

If the read count is different, then it is most likely because you aren’t working with the same data (or the data has been pre-processed separately).

The importing process does not transform these data in any way, it simply copies the files into a QIIME 2 Artifact - that means you had those read counts prior to QIIME 2 with these data.

I suggest you coordinate with your colleague to ensure you both get on the same page. Keep us posted!

:qiime2:

Thank you.
Is it possible that the reason for this difference be on my part? based on the information I given to you and I sent you one the samples pictures, can I be sure I did the import process correctly? Although this process is not very difficult, but I need to make sure I did not made a mistake. My files consist of 12 forward files and 12 reverse files as you can see, and I used the command I mentioned to import them. I created a manifest file and import the files.
is it possible that this different in reads be my mistake or not?
Thank you in advance

Hi @mohsen_ej - QIIME 2 does not transform these data in any way, so there is no way for you to specify an import command that makes “a mistake.” I am confident that the issue you are observing here is because you are comparing two different datasets (or stages of the datasets). One option to confirm this is to open a QIIME 2 conda environment, cd into the directory with your fastq files, and run the following:

for f in *.fastq; do r=$(( $(wc -l < $f | tr -d '[:space:]') / 4 )); echo $r $f; done

If you run that, please share the results here with us. This will count the number of reads in each sample file, similarly to the demux summarize command you ran above.

Thanks!


These are the results. apparently, they are as same as the previous result.

Thanks for sharing @mohsen_ej, so now hopefully you can see, the data is unchanged when imported into QIIME 2 - you can rest assured that you didn’t accidentally do something to cause this (as you expressed concern for above).

1 Like

Thank you very much.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.