Lots of installation and package conflicts

Hi,

trying to install qiime2-2021.11 natively on a Mac running Mojave (been using qiime2-2020.8 until now). Updated conda. I got a ton on conflicts for incompatible packages upon installing not sure what is going on. Any suggestions? Thanks :slight_smile:

(base) MBP-MACPRO:~ mpb$ conda update conda

Collecting package metadata (current_repodata.json): done
Solving environment: done

All requested packages already installed.

(base) MBP-MACPRO:~ mpb$
(base) MBP-MACPRO:~ mpb$ wget https://data.qiime2.org/distro/core/qiime2-2021.11-py38-osx-conda.yml
--2022-01-14 09:27:46-- https://data.qiime2.org/distro/core/qiime2-2021.11-py38-osx-conda.yml
Resolving data.qiime2.org (data.qiime2.org)... 54.200.1.12
Connecting to data.qiime2.org (data.qiime2.org)|54.200.1.12|:443... connected.

HTTP request sent, awaiting response... 302 FOUND
Location: https://raw.githubusercontent.com/qiime2/environment-files/master/2021.11/release/qiime2-2021.11-py38-osx-conda.yml [following]
--2022-01-14 09:27:47-- https://raw.githubusercontent.com/qiime2/environment-files/master/2021.11/release/qiime2-2021.11-py38-osx-conda.yml
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.110.133, 185.199.111.133, 185.199.108.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.110.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 8627 (8.4K) [text/plain]
Saving to: ‘qiime2-2021.11-py38-osx-conda.yml’

qiime2-2021.11-py38 100%[===================>] 8.42K --.-KB/s in 0s

2022-01-14 09:27:47 (23.6 MB/s) - ‘qiime2-2021.11-py38-osx-conda.yml.1’ saved [8627/8627]

(base) MBP-MACPRO:~ mpb$
(base) MBP-MACPRO:~ mpb$ conda env create -n qiime2-2021.11 --file qiime2-2021.11-py38-osx-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: |
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.

==== The result after 20 minutes or so was a very long list of packages with issues. I tried to update conda again, same result.

Hi @mpodar, my guess is you're running on a new Apple Silicon mac - this is a completely different architecture from what we distribute. Let's confirm, by running the following:

conda info

Thanks!

1 Like

hi Matthew,
its actually an old machine, 2018. Here is the output:

user-agent : conda/4.11.0 requests/2.27.1 CPython/3.7.12 Darwin/18.7.0 OSX/10.14.6

You have more than one copy of the environment file in this directory. Please try removing all of them and downloading the environment file again.

Keep us posted!

:qiime2:

Well, I removed some but not all. I am worried about removing my working Qiime2 version, and in the past it was possible to have multiple versions, so not quite sure, is the 2021.11 incompatible with having older environments still present?

Here is what I got:

(base) MBP-MACPRO:~ mpb$ conda env list

conda environments:

                    /Users/mpb/miniconda3

base * /opt/miniconda3
qiime2-2020.8 /opt/miniconda3/envs/qiime2-2020.8

Upon updating conda

The long list of conflicts still came... If I get rid of the qiime2-2020.8 and that doesnt fix the problem then Im crippled...

I have good news for you: the environment files are not the same thing as the actual environments. You can safely remove the environment files after creating an environment (in fact, our install instructions suggest exactly that).

The reason I'm suggesting you remove the yml files is because you clearly have more than one in this directory (that's what the command above tells us), and I'm wondering if something went wrong with the yml environment file download, initially. So my suggestion is let's clean all this stuff up and start from a clean slate.

1 Like

Thanks. I deleted all the .yml files from the entire hard drive, there were about 100 or so for various things. Unfortunately that did not fixed the issue. I wonder though if its the many conda updates that leave environment files of many vintages for various things . Here is a screenshot of a fraction of the packages in the miniconda directory, shows multiple versions of some. Perhaps the new qiime2 version install doesnt like seing such legacy things ? (it didnt use to be the case, unless something went out of whack on my machine). Perhaps I should delete the entire minoconda3 and reinstall.

Oh no! Please see my note above (emphasis added):

I hope you didn't break anything on your system by removing those other files.

Can you run conda list for us and share the results here?

hi Matthew

problem finally solved. I was getting some extra errors, probably messed some other things. So I re-installed the whole miniconda 3 and then the latest version of qiime2 installed just fine. Thanks !

Mircea

1 Like