losing lots of data after denoising

Hi there,
I am using qiime2-2021.8.
I followed the qiime2 tutorial on how to dada2 denoising data but I lost lots of data. Please see attached denoising stats. Could you please let me know what is possibly causing this?
the command I used was:
qiime dada2 denoise-paired
--i-demultiplexed-seqs paired-end-demux.qza \
--p-trim-left-f 15
--p-trim-left-r 15
--p-trunc-len-f 180
--p-trunc-len-r 180
--o-table table.qza
--o-representative-sequences rep-seqs.qza
--o-denoising-stats denoising-stats.qza
Thank you so much in advance, Paula.

looks like you are loosing reads mostly on the merging step, meaning that forward and reverse reads do not overlap. Try to increase --p-trunc-len parameters so you will have longer reads after truncation and add --p-min-overlap 6 line to the command. That will allow you to set minimum overlapping region to 6 instead of default 12 (or set it to any other number you would like to test).

Hi Timur
Thank you so much.
One quick question where does the argument of min overlap of 6 goes? Please see the snapshot I get an error when i tried to input that argument.
Thank you so much, Paula.

By default minimum overlapping region in Dada2 is 12. That's mean that forward and reverse reads should be overlapping with each other for at least 12 bp in order to be merged. If your reads are too short, but still overlap, setting min overlap parameter in Dada2 to the lower value may help to merge the reads (6 means that 6 nt should be overlapping).
If your reads are too short and do not overlap at all, only forward reads (or only reverse reads) could still be used for the analysis (with a cost of the quality of taxa annotation).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.