Longitudinal first-distances plugin error with metadata

Hi everyone!

This may be a really easy fix, but I’ve tried to tweak the metadata with no luck so far.
I’m trying to run the longitudinal analysis on a distance matrix (bray-curtis) using the following command:

qiime longitudinal first-distances --i-distance-matrix bray_curtis.qza --m-metadata-file mapping_V1V3_new.txt --p-state-column Timepoint --p-individual-id-column sample-id --p-replicate-handling random --output-dir first-distances

And get the following error:

 Plugin error from longitudinal:

  sample-id is not a column in your metadata

Debug info has been saved to /tmp/qiime2-q2cli-err-1kr4e6n5.log

Each of the sampleIDs should be unique, but I’m not sure why qiime is not able to read the header in the first place. I was able to generate emperor plots using the same distance matrix and mapping metadata, and didn’t run into any errors then. I’ve tried to replace the “sample-id” with “#sample-id”, as was in the case of Qiime 1, but it still errors out.

I’ve attached the metadata and am currently running QIIME 2 version: 2019.4. Please let me know if you need anything else!

mapping_V1V3_new.txt (3.9 KB)

Hi there @drish_k!

The error message is telling the truth, and I admit, it is probably a little confusing at first, but let me draw your attention to the docs:

https://docs.qiime2.org/2019.7/tutorials/metadata/#identifier-column

The “identifier column” is a special column to QIIME 2, with special requirements (all values must be unique). This ID column isn’t exposed as a usable column for analysis, because the IDs are usually just used to related pieces of data to each other.

If you want to use your sample IDs, simply make a new column, with a new name, that contains the sample IDs.

:t_rex: :qiime2:

2 Likes

Yep, that’s exactly what I ended up doing. Just wasn’t sure if that’d be redundant or not.

Thanks!