Issue with generate rep-seqs-dada2.qza file

Hello I tried two command
qiime vsearch dereplicate-sequences
–i-sequences demux-single-end.qza
–o-dereplicated-table table-dada2.qza
–o-dereplicated-sequences rep-seqs-dada2.qza \

and command
qiime dada2 denosise-single
–i-demultiplexed-seqs demux-single-end.qza
–p-trim-left 0
–p-trunc–len 400
–p-n-threads 4
–o-table table-dada2.qza
–o-representative-sequences rep-seqs-dada2.qza

but these commands only generate table-dada2.qza for me, there is no rep-seqs-dada2.qza.

Coould anyone help me, find out what part of my command went wrong?

Thanks for your help

Hi @zhang_sonic! Can you please provide the following info?

  1. The output from running qiime info
  2. Are you receiving error messages for either of those commands? If so, please post the full error messages. If you’re not receiving error messages, can you confirm that the commands finished running? A screenshot of the commands you’re running and the output they produce may be helpful.

Also note: both of your commands are using the same output file paths to save results (table-dada2.qza and rep-seqs-dada2.qza). Whichever command you run last will overwrite any existing files with the new results. I recommend using different file paths to save the results from each command to avoid overwriting the files. Also note that the output filenames you’re using with qiime vsearch dereplicate-sequences are a bit misleading; the vsearch command isn’t using DADA2 denoising, it is only dereplicating the sequences. You might consider using different filenames to better indicate what the results represent, in order to avoid mixing up your data.

1 Like

hi jairideout

Thanks for your help.
Here is where I started

then I ran this command

I ran top command and made sure it was running

Then when it was finished this is what I got

See only the table-dada2-2018.qza was generated, and there is no rep-seqs-dada2-2018.qza.

And I have no idea about where went wrong.

Thanks for the details! Can you try rerunning the DADA2 command directly, this time without using Ctrl+Z, bg, jobs, and disown? I wonder if those commands are somehow interfering with the DADA2 command you’re running.

If the command succeeds, you should see output similar to:

Saved FeatureTable[Frequency] to: table-dada2-2018.qza
Saved FeatureData[Sequence] to: rep-seqs-dada2-2018.qza

If that doesn’t work, can you please send a screenshot of the command you ran and any output it produced? Thanks!

1 Like

Hi Jairideout

I tried this command and let it run without doing anything else just like what you have suggested, and it worked this time. Finally. Thanks for your help.

qiime dada2 denoise-single
–i-demultiplexed-seqs demux-single-end.qza
–p-trim-left 0
–p-trunc-len 400
–p-n-threads 4
–o-table table-dada2-2018.qza
–o-representative-sequences rep-seqs-dada2-2018.qza
–output-dir /home/Ubuntu/qiime2



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.