issue converting biom to tsv

Hi, i've been trying to convert a biom file to a tsv file. I looked at all similar questions and used the code suggested (with the names changed to fit my files.

This is the code i used:
biom convert
-i table.biom/feature-table.biom
-o feature-table.tsv --to-tsv

I also read the suggestion to change directory to the more local one these files are in so I'm now working in the directory called Biom wiche contains table.biom.

Despite all this I keep getting the same error.
Error: Missing option '-i' / '--input-fp'.
This is the same error that other users seem to have been able to solve by using this code and by changing the directory as I did but clearly I am still missing something.

Could anyone help?

Hello @Imke_Tys,

If you break the command across multiple lines you have to include backslashes \. Or try putting all those lines on the same line in the terminal and then press enter.

thank you so much, i kinda want to kick myself for missing something so obvious but it works now so thanks.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.