installing qiime in windows 10 using bash cell

Hi there,
I am trying to install qiime 2 in my windows 10. I do have windows system for linux and have activated Bash cell. I already installed Miniconda 3 for linux and then tried “conda update conda
conda install wget” commands with no problem. When I tried to install qiime 2 using

wget "https://data.qiime2.org/distro/core/qiime2-2019.7-py36-linux-conda.yml
conda env create -n qiime2-2019.7 --file qiime2-2019.7-py36-linux-conda.yml
# OPTIONAL CLEANUP
rm qiime2-2019.7-py36-linux-conda.yml" I get error message "permission denied"
wget https://data.qiime2.org/distro/core/qiime2-2019.7-py36-linux-conda.yml
Will not apply HSTS. The HSTS database must be a regular and non-world-writable file.
ERROR: could not open HSTS store at '/home/alexander/.wget-hsts'. HSTS will be disabled.
--2019-09-01 14:17:13--  https://data.qiime2.org/distro/core/qiime2-2019.7-py36-linux-conda.yml
Resolving data.qiime2.org (data.qiime2.org)... 52.35.38.247
Connecting to data.qiime2.org (data.qiime2.org)|52.35.38.247|:443... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: https://raw.githubusercontent.com/qiime2/environment-files/master/2019.7/release/qiime2-2019.7-py36-linux-conda.yml [following]
--2019-09-01 14:17:13--  https://raw.githubusercontent.com/qiime2/environment-files/master/2019.7/release/qiime2-2019.7-py36-linux-conda.yml
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.52.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.52.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6287 (6.1K) [text/plain]
qiime2-2019.7-py36-linux-conda.yml: Permission denied

Cannot write to ‘qiime2-2019.7-py36-linux-conda.yml’ (Success).

I am wondering what’s going on during installation and what I can do to get this work.
Thanks

Welcome to the Qiime 2 forums :qiime2:

I’m glad you are getting qiime installed through windows subsystem for linux. Hopefully we can fix this error easily:

This means your account does not have permission to make that file. What folder are you in when running that command? Have you tried running it from your home folder?

Thanks!

Colin

thanks for prompt reply. I was in Windows system folder when I tried the command ( [email protected]:/mnt/c/Windows/System32$)
then I tried it in [email protected]:/mnt/c/Windows (which is my root)
I still get the same error message as before.

could this be I do not have administration rights in my account? This is a computer set up by the university and I requested for an admin account

Thanks

Yes, this could be the issue! Even if you don’t have admin access, they should be able to give you read/write access.
(I think this error is caused by not having write access.)

Let me know what you find!
Colin