Installation failure on MacOS Sierra

Hi there! I am trying to install the qiime2 on the MacOS HighSierra 64bit desktop, connected to the university network (specified because noticed some weird info regarding this).
Installed miniconda3 without issue, but then on the actual retrieval step:

wget https://data.qiime2.org/distro/core/qiime2-2018.4-py35-osx-conda.yml

I am getting this:

--2018-06-21 15:30:26--  https://data.qiime2.org/distro/core/qiime2-2018.4-py35-osx-conda.yml
Resolving data.qiime2.org... 104.27.170.158, 104.27.171.158
Connecting to data.qiime2.org|104.27.170.158|:443... connected.
OpenSSL: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
Unable to establish SSL connection.

Tried updating wget through conda, but still doesn’t work. Tried:

conda config --set ssl_verify no

Still doesn’t work.

Hoping for help from you brilliant people!

hm, try it without the https://

wget http://data.qiime2.org/distro/core/qiime2-2018.4-py35-osx-conda.yml

2 Likes

You don’t have to use wget - you can just visit that URL in your browser and download to a known location on your machine. Then, in your terminal, navigate to that location, and proceed with the install directions.

You might still have more issues (related to certificates), but let’s play that by ear :ear:

:qiime2: :t_rex:

1 Like

Yep, you are right.

I ended up using “curl -O …” to download it from terminal.
Thanks anyway!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.