Install issue-This transaction has incompatible packages due to a shared path

I tried to install the new version of the qiime2, but there is always an error "ClobberError: This transaction has incompatible packages due to a shared path.
packages: conda-forge::traitlets-4.3.2-py35_0, conda-forge::pip-18.0-py35_1001
path: ‘lib/python3.5/site-packages/pip/_vendor/webencodings/pycache/labels.cpython-35.pyc’.

I have used " Use conda clean --packages to fix it, but it still does not work.

Could you please help me to address it? Thanks so much!

Sorry for the delay @tengfey — the QIIME 2 team has back-to-back workshops these two weeks so responses are slow.

Try conda clean --all

You could also try updating conda.

If that does not fix this issue, could you please post the full error message from conda? It may contain additional context we need to solve this. Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.