importing repr_set.fasta file from QIIME1 into QIIME2-2019.7

I am new to this QIIME1 and 2
we have used QIIME1 for generating repr_set.fasta file through multistep OTU picking steps.
is it possible to import this fasta file into QIIME2 and proceed the further analysis like Assigning Taxonomy, Classify query sequences using vsearch, qiime taxa filter-table,Generating a phylogenetic tree,Alpha and Beta diversities analysis, etc.

i tried to import with the following command
qiime tools import --input-path /home/Q21/WD/WD_repr_set.fasta --output-path /home/Q21/WD/reads_qza/WD_seqs.qza --type ‘SampleData[Sequences]’

but received an error
There was a problem importing /home/Q21/WD/WD_repr_set.fasta:
/home/Q21/WD/WD_repr_set.fasta is not a(n) QIIME1DemuxFormat file

then thought to remove the small letter charcaters, by
tr ‘acgt’ ‘ACGT’ < /home/Q21/WD/WD_repr_set.fasta > /home/Q21/WD/WD_repr_seqs.fna

then tried again for import
qiime tools import --input-path /home/Q21/WD/WD_repr_seqs.fna --output-path /home/Q21/WD/reads_qza/WD_seqs.qza --type ‘SampleData[Sequences]’

There was a problem importing /home/Q21/WD/WD_repr_seqs.fna:

/home/Q21/WD/WD_repr_seqs.fna is not a(n) QIIME1DemuxFormat file


is it possible to import in QIIME2 and do the other steps to proceed as mentioned above.


Hi @prabugr,
You are importing as the wrong type. Try this:

qiime tools import \
  --input-path /home/Q21/WD/WD_repr_seqs.fna \
  --output-path /home/Q21/WD/reads_qza/WD_seqs.qza \
  --type 'FeatureData[Sequence]'

thank you. it got worked

after this step success, we have tried to get the FeatureTable[Frequency] - WD_table.qza

command used :
qiime vsearch dereplicate-sequences --i-sequences /home/Q21/WD/reads_qza/WD_seqs.qza --o-dereplicated-table /home/Q21/WD/feature_table/WD_table.qza --o-dereplicated-sequences /home/Q21/WD/feature_seq/WD_rep-seqs.qza
Usage: qiime vsearch dereplicate-sequences [OPTIONS]

Dereplicate sequence data and create a feature table and feature representative sequences. Feature identifiers in the resulting artifacts will be the sha1 hash of the sequence defining each feature. If clustering of features into OTUs is desired, the resulting artifacts can be passed to the cluster_features_* methods in this plugin.

–i-sequences ARTIFACT SampleData[Sequences] |
SampleData[SequencesWithQuality] | SampleData[JoinedSequencesWithQuality]
The sequences to be dereplicated. [required]
–p-derep-prefix / --p-no-derep-prefix
Merge sequences with identical prefixes. If a
sequence is identical to the prefix of two or more
longer sequences, it is clustered with the shortest
of them. If they are equally long, it is clustered
with the most abundant. [default: False]
–o-dereplicated-table ARTIFACT FeatureTable[Frequency]
The table of dereplicated sequences. [required]
–o-dereplicated-sequences ARTIFACT FeatureData[Sequence]
The dereplicated sequences. [required]
–output-dir PATH Output unspecified results to a directory
–verbose / --quiet Display verbose output to stdout and/or stderr
during execution of this action. Or silence output
if execution is successful (silence is golden).
–citations Show citations and exit.
–help Show this message and exit.

                There was a problem with the command:

(1/1) Invalid value for “–i-sequences”: Expected an artifact of at least
type SampleData[Sequences] | SampleData[SequencesWithQuality] |
SampleData[JoinedSequencesWithQuality]. An artifact of type
FeatureData[Sequence] was provided.

please help

thus your rep seqs are already dereplicated, and you have a feature table. No need to dereplicate as you are now attempting to do.

thanks, is it possible to check number of threads used in each step?

only the step - qiime feature-classifier classify-consensus-vsearch have the command of --p-threads,

if we can include the number of threads to use, then we can speed up the process and output, few of the steps are consuming much more time

thanks, we proceeded further steps - qiime feature-classifier classify-consensus-blast

we tried the step Filter the Feature Table

qiime taxa filter-table --i-table /home/srini1/Q21/modified/WD/feature_table/unfiltered-table.qza --i-taxonomy /home/srini1/Q21/modified/WD/taxonomy.qza --p-exclude mitochondria,chloroplast,unknown,metazoa --o-filtered-table /home/srini1/Q21/modified/WD/taxa_filter/WD-table-noplant.qza

but getting the following error

Plugin error from taxa:

CategoricalMetadataColumn does not support values with leading or trailing whitespace characters. Column ‘Taxon’ has the following value: "D_0__Bacteria;D_1__Proteobacteria;D_2__Gammaproteobacteria;D_3__Chromatiales;D_4__Sedimenticolaceae;D_5__uncultured;D_6__Escarpia spicata endosymbiont 'Alvin "

Debug info has been saved to /tmp/qiime2-q2cli-err-y0w8b3jh.log

please help

it is always 1 by default

classify-sklearn has an n_jobs parameter — many QIIME 2 actions have either n_jobs or n_threads parameters.

your taxonomy IDs have empty spaces on the end, which is causing this error. This is coming from the database that you are using, not from QIIME 2, so you can correct in the reference taxonomy before importing. Otherwise there are some workarounds for fixing your taxonomy classifications at this stage — you can search the forum archive for some examples.

Good luck!

thanks for the support.

please suggest the steps for the following

i am having the following files generated from Parallel-Meta using my metagenome shotgun sequences.

  1. taxa.OTU.Count for multiple samples (single file)
  2. taxa.OTU.abd for multiple samples (single file)
  3. Taxonomical level profile files - taxa.genus.COUNT, taxa.genus.abd for multiple samples
  4. Classification.txt - for individual samples

is it possible to use these files to import and use in QIIME.
Which file to use as OTU file, taxonomy file and how to import them into QIIME
if the classification.txt file has to be used as taxonomy file, then how to merge those individual sample specific classification.txt files into single to import into QIIME

Expecting inputs at the earliest.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.