importing reference data sets

(Faiga Magzal) #1

Hello,
I’ve been trying to import greengenes files into qiime2 to use them as reference data sets. I downloaded the files below and it is not working…
Gg_13_8_99.taxonomy.tgz
and
gg_13_8_otus.tar.gz
Did I download the wrong files? If yes, where can I find the correct files to download?
Please help,
Thank you in advance
Faiga

(Mehrbod Estaki) #2

Hi @Faiga,
You can find these files in the data-resources page.

Unfortunately this doesn’t provide any useful information for us help troubleshoot with. Could you please give us some more details with regards to what exactly you are doing, what commands you are running, what’s the error messages etc.

(Faiga Magzal) #3

Hi @Mehrbod_Estaki,
Sorry for the poor explanation, please ignore the files written before. Bioinformatics is not my field so I am trying to work things out using the tutorials. I started by importing my sequences and performing all stages using the “Moving pictures tutorial”. Everything went fine untill I reached the " Taxonomic analysis". I downloaded the “gg-13-8-99-515-806-nb-classifier.qza” file and performed the commands:
qiime feature-classifier classify-sklearn
–i-classifier gg-13-8-99-515-806-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza
I recieved the error:
Plugin error from feature-classifier:
Debug info has been saved to /tmp/qiime2-q2cli-err-dbih48ag.log
Thanks for trying to help.
Faiga

(Mehrbod Estaki) #4

Hi @Faiga,

No problem! This is what we’re here for, we’ve all been there at the starting line. Just plugging away, the only way to get better :slight_smile:
The full error we need has been saved in /tmp/qiime2-q2cli-err-dbih48ag.log, however since that is a temporary file it is likely automatically deleted by now already. Could you please re-run your code and add the --verbose parameter to it. Then copy & paste the full error here.

In addition, I should also mention that the pre-trained classifier you are using is specific to the V4 region with the 515-806 primers. You can use this if that is the region you sequenced otherwise you may want to either train your own or use the full-length classifier available. The former will be a bit better but more computationaly expensive.

2 Likes
(Faiga Magzal) #5

Hi @Mehrbod_Estaki,
Thanks for helping.
Should I add --verbose to the commands like this?
qiime feature-classifier classify-sklearn
–i-classifier /media/sf_XXX/gg-13-8-99-515-806-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza
–verbose
Thanks for the patience,
Faiga

(Jono Warren) #6

Like this yes:

qiime feature-classifier classify-sklearn \
--i-classifier /media/sf_XXX/gg-13-8-99-515-806-nb-classifier.qza \
--i-reads rep-seqs.qza \
--o-classification taxonomy.qza \
--verbose
1 Like
(Faiga Magzal) #7

Thanks!
I ran the command:
qiime feature-classifier classify-sklearn --i-classifier gg-13-8-99-nb-classifier.qza --i-reads rep-seqs.qza --o-classification taxonomy.qza --verbose

And this is was I got:
Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2019.1/bin/qiime”, line 11, in
sys.exit(qiime())
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/q2cli/commands.py”, line 244, in call
arguments, missing_in, verbose, quiet = self.handle_in_params(kwargs)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/q2cli/commands.py”, line 326, in handle_in_params
kwargs, fallback=cmd_fallback)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/q2cli/handlers.py”, line 375, in get_value
artifact = qiime2.sdk.Result.load(path)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/qiime2/sdk/result.py”, line 66, in load
archiver = archive.Archiver.load(filepath)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/qiime2/core/archive/archiver.py”, line 299, in load
archive = cls.get_archive(filepath)
File “/home/qiime2/miniconda/envs/qiime2-2019.1/lib/python3.6/site-packages/qiime2/core/archive/archiver.py”, line 264, in get_archive
raise ValueError("%s is not a QIIME archive." % filepath)
ValueError: gg-13-8-99-nb-classifier.qza is not a QIIME archive.
:astonished:

I hope it makes sense to you,
Thanks for helping.
Faiga

(Mehrbod Estaki) #8

Hi @Faiga,
That is odd indeed. Did you download the gg-13-8-99-nb-classifier.qza directly from the resources page or did you make this yourself with some modifications? If you downloaded it directly, could you try re-downloading it? It may be that it was just an incomplete download or somehow corrupted. Give that another try. Also since you are using the 2019.1 version of qiime2 could you also make sure you use the drop-down menu on the top-left of the resource page to change it to this version before downloading and let us know how that goes.

(Faiga Magzal) #9

Hi @Mehrbod_Estaki,
Thanks for answering.
I downloaded directly from the resources page.
I tried to download it again (making sure to use the 2019.1 version).
I still didn’t work.
Can you think of any other idea?
Thanks for helping,
Faiga

(Mehrbod Estaki) #10

Hi @Faiga,
:thinking:… Would you be able to share with us the rep-seqs.qza file you are using so we can try and recreate the error? You can DM that if you rather not post it here.

(Mehrbod Estaki) #13

Alternatively, you can also use qiime tools peek and qiime tools validate to see if the downloaded classifier is in the proper format since the error message suggests that seems to be the source of the problem:

ValueError: gg-13-8-99-nb-classifier.qza is not a QIIME archive.