Importing per sample reads using manifest file

Hi there,

I am currently running qiime2-2017.12 (because that is the most recent version available). Despite having successfully managed to import my per sample sequence files in the newest version, I’m now running into problems. I have created a manifest file and tried both csv and txt file versions. However I am getting this:

(qiime2-2017.12) [[email protected] ejm3n17]$ qiime tools import --type ‘[SampleData[SequencesWithQuality]’ --input-path manifest.txt --output-path /GM/single-end-demux.qza --source-format SingleEndFastqManifestPhred33

Traceback (most recent call last):
File “/local/software/miniconda/conda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2cli/tools.py”, line 116, in import_data
view_type=source_format)
File “/local/software/miniconda/conda3/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/result.py”, line 177, in import_data
type_ = qiime2.sdk.parse_type(type_)
File “/local/software/miniconda/conda3/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/util.py”, line 62, in parse_type
type_expr = eval(string, {‘builtins’: {}}, locals_)
File “”, line 1
[SampleData[SequencesWithQuality]
^
SyntaxError: unexpected EOF while parsing

An unexpected error has occurred:

unexpected EOF while parsing (, line 1)

See above for debug info.

Thanks for any help!

Hello @eviejmorris, I notice you have a leading ‘[’ in your line '–type ‘[SampleData[SequencesWithQuality]’, I am unfamiliar with qiime2-2017.12, but could this be the source of the issue?

3 Likes

Hi there, that’s a typo in my original post. I have just re-run this without the first [ and recieve the same error:
"There was a problem importing manifest.txt:

manifest.txt is not a(n) SingleEndFastqManifestPhred33 file"

Hey there @eviejmorris, this looks like an all new error, we are making progress!

I just noticed that you are running an extremely old version of QIIME 2 (2017.12) --- any chance you can upgrade to a new version? The latest version of QIIME 2 provides much better guidance on these kinds of import errors (this error is obtusely stating that your manifest file is mis-formatted).

:t_rex: :qiime2:

Yes, I am currently in an argument with our IT providers about the version…

Anyway, having trawled the internet and reformatted the file a million times this seems like another time that excel was adding extra bits to my file! It has finally worked. Thanks to all for all your help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.