importing data using paired end sequences

Hi,
I’m trying to import my data to QIIME2.
My data looks like this:
193-Cl-6_S9_L001_R1001.fastq.gz
193-Cl-6_S9_L001_R2001.fastq.gz

I am using the command :

qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path /media/sf_All_orders/ --source-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

I keep getting the error message:
“Missing one or more files for CasavaOneEightSingleLanePerSampleDirFmt: ‘.+_.+_L[0-9][0-9][0-9]_R[12]_001\.fastq\.gz’”

What am I doing wrong?
Please help,
Faiga

Hi @Faiga,

I would recommend trying the manifest format, which will probably be your path of least resistance. Despite the format for casava, there are still enough weird variants that it’s easier than trying to find the perfect naming format.

Best,
Justine

Hi Justine,
Thank you for your answer.
Should I change the name of all files according to the manifest format?
Faiga

Hi @Faiga,

Nope, the best part of the manifest is that you don’t need to rename the files, just follow the directions to build the file.

Best,
Justine

Justine,
I really appreciate you help. Thank you very much.
Unfortunately, I still couldn’t make it. My commands were:
qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path /media/sf_FASTAQ_XXX
–output-path paired-end-demux.qza
–input-format PairedEndFastqManifestPhred64V2 \

The result was:

Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/util.py”, line 91, in parse_format
format_record = pm.formats[format_str]
KeyError: ‘PairedEndFastqManifestPhred64V2’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2018.11/lib/python3.5/site-packages/q2cli/tools.py”, line 140, in import_data
view_type=input_format)
File “/home/qiime2/miniconda/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/result.py”, line 206, in import_data
view_type = qiime2.sdk.parse_format(view_type)
File “/home/qiime2/miniconda/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/util.py”, line 93, in parse_format
raise TypeError(“No format: %s” % format_str)
TypeError: No format: PairedEndFastqManifestPhred64V2

An unexpected error has occurred:

No format: PairedEndFastqManifestPhred64V2

See above for debug info.

I have no idea of how to solve the problem…
Could you please help?
Thanks again,
Faiga

Hi @Faiga,

If you look at your error message, you’ll see it tells you the problem:

So, you need to find a correct format for your data

qiime tools import --show-importable-formats

(or some variant thereof… the help documentation is my best friend for flags and spelling) should tell you the importable formats and then just pick one that matches your type. Typically, if Im doing paired end at Phred64 doesnt work, I’ll try Phred33… or check with your sequencing center to determine what format you got.

Best,
Justine

1 Like

Hi @Faiga ,

Please also do my suggestion and follow the following protocol:

-Create two directories which the first one should be inside the second one.
-Put just 193-Cl-6_S9_L001_R1001.fastq.gz file inside the first directory.
-rename the file from 193-Cl-6_S9_L001_R1001.fastq.gz to forward.fastq.gz
-open a new terminal in the second directory, not the first one.
-avoid having the reverse file or 193-Cl-6_S9_L001_R2001.fastq.gz file beside the forward file.
-run the importing Casava format on your forward sequence already renamed.
-you cannot miss it:wink:
just keep us updated

Hi @Faiga! The error you are seeing above is due to the fact that you are specifying a format (PairedEndFastqManifestPhred64V2) that was added in QIIME 2 2019.4, but you appear to be using an older QIIME 2 (2018.11). Options to move forward include upgrading to 2019.4, or, using the documentation specific for 2018.11.

1 Like

Hi Matthew,
Thank you very much. I will try to update.
Faiga

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.