Importing data tutorial - failure again?

Hey all,

after a very disillusioning experience with the moving-pictures tutorial, again I’m facing issues with the importing data tutorial, part Casava 1.8…

The browser download creates a new and unzipped folder “casava-18-single-end-demultiplexed” in my Downloads and this folder contains 138 fastq.gz files.

Because the tutorial says “save as .zip” I tried to zip the folder by
zip casava-18 zip error: Nothing to do! (casava-18.zip)
Which means to me, that obviously the folder is zipped somehow.

So, I proceeded with the tutorial:
unzip -q casava-18.zip unzip: cannot find or open casava-18.zip, casava-18.zip.zip or casava-18.zip.ZIP.
same for unzip -q casava-18

Because the folder obviously is not zipped, I hoped for the best and ran the code:

qiime tools import \
  --type 'SampleData[PairedEndSequencesWithQuality]' \
  --input-path casava-18-paired-end-demultiplexed \
  --input-format CasavaOneEightSingleLanePerSampleDirFmt \
  --output-path demux-paired-end.qza

and tadaaa! Worked!

Now I wanted to see demux-paired-end.qzv by

qiime demux summarize \
> --i-data demux-paired-end.qza \
> --o-visualization demux-paired-end.qzv

Press the ‘q’ key, Control-C, or Control-D to quit. This view may no longer be accessible or work correctly after quitting.
So, I have to quit the whole qiime session every time, I want to see the results? Is that normal?

Thank you!

Hi @Lacona. Please try to refine your topics to one question whenever possible. It will make it easier for other forum users to answer them.

I think you may be confused about what’s happening here. You probably received that message after running qiime tools view demux-paired-end.qzv, not qiime demux summarize. A “QIIME 2 Session” isn’t really a thing that exists. Generally, when you run a QIIME 2 command, QIIME 2 runs until it is finished, and then it stops. Once it stops, QIIME 2 isn’t “on” any more. While it is running, you’ll notice that you don’t have access to the command prompt. Once it stops, you get control back.

qiime tools view is an exception to this rule. It opens a new browser tab in which to display your visualization. In order to do so, it needs to “serve” the data in your .qzv to the browser. Because it doesn’t know for how long you want to look at your .qzv, it just keeps serving the data up until you tell it to stop yourself. When you q, ctrl-c, etc, you are just telling your terminal to stop the qiime tools view process, so you can get back to your analysis.

Hope that clears things up!

CK :bat:

2 Likes