Importing data for closed-reference

Gil, i made the same thing, about i dont got the same result:
!qiime tools import --type FeatureData[Sequence] --input-path rep_set/99_otus.fasta --output-path 99_otus.qza

!qiime vsearch cluster-features-closed-reference --i-sequences rep-seqs.qza --i-table table.qza --i-reference-sequences 99_otus.qza --p-perc-identity 0.99 --o-clustered-table 99closereftable --o-unmatched-sequences 99closeref_unmatchedseqs

I got this error:
Plugin error from vsearch:

Argument to parameter ‘reference_sequences’ is not a subtype of FeatureData[Sequence].

Debug info has been saved to /var/folders/g6/6hwq_0454f97jwwm56lbpsw00000gn/T/qiime2-q2cli-err-6r7j351o.log

When I visualize the 99otu.qza file, i can confirm that the file type is FeatureData[Sequence].

Hi Deborah,

Sorry, I have no idea what might have gone wrong, especially since you verified it was a FeatureData[Sequence] type file. I’m hope others can help.


Hi @Deborah_Leite,

That is terribly strange. Would you be able to navigate to the directory you ran qiime vsearch cluster-features-closed-reference in and run:

qiime tools peek 99_otus.qza

It also looks like you are using something like a Jupyter Notebook since you are prefixing your commands with !, if that isn’t the case, could you elaborate on what kind of a shell/environment you are running these commands in?

My first guess here is somehow the directory you are running the commands in is getting mixed up, and you somehow have two files called 99_otus.qza with different types. But that’s just a guess.

1 Like

Does anyone already have a 99_otus.qza file that can send me?

When I run : qiime tools peek 99_otus.qza
I got it:
UUID: af6d0c35-7ff5-4fcc-bcf5-24504fc25ff9
Type: FeatureData[Sequence]
Data format: DNASequencesDirectoryFormat

Now I will try.

Hi @Deborah_Leite — looks like your file called 99_otus.qza is of the right Type — are you still experiencing this issue when you use it, or did you get this straightened out on your end? Thanks! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.