Import fastq file from split_libraries_fastq.py

Hello,
I am new to qiime2 and I’m working on importing my own data produced by Ion Torrent PGM. I have read many suggestions since I have not found a specific tutorial for Ion Torrent data and many users have told me to do the split_libraries_fastq.py before (QIIME1) importing in QIIME2.
So I have run this script:
split_libraries_fastq.py -i file.fastq --store_demultiplexed_fastq --sample_ids file.fastq -q 19 --phred_offset 33 -o file"_split" --barcode_type not-barcoded.

my output file are (e.g. for the sample 1_DX):
1_DX.fastq
1_DX.fna
histograms.txt
split_library_log.txt

So I tried to import the fastq files with:
qiime tools import
–type ‘SampleData[SequencesWithQuality]’
–input-path Fastq/
–output-path demux-single-end.qza

but I had this error message

There was a problem importing /Users/rparadiso/Documents/Progetti/Microbiota_orecchio_cane/QIIME_analysis/Prova_analisi/Prova_1/Fastq:

/Users/rparadiso/Documents/Progetti/Microbiota_orecchio_cane/QIIME_analysis/Prova_analisi/Prova_1/Fastq is not a file.

Can someone help me please?
I worked at this analysis from many weeks but I can’t find a solution. Work with Ion Torrent data is very stressful

Hi there @rparadiso!

The --input-path should point to your manifest file, not the directory with your sequences.

Can you post your manifest file, that way we can take a look?

Also, have you review the Manifest file section of the Importing tutorial?

:t_rex: :qiime2:

Hi Matthew,
attached my manifest. It is a file .txt!

52|649x406

thank you for your help

Hi @rparadiso --- I don't see an attachment, can you please try again?


BEGIN SCREENSHOT

00%20AM

END SCREENSHOT


52

1 Like

Your manifest looks good to me — have you tried running the command I suggested above with the --input-path being set to this file, instead of the directory Fastq/? It looks like here your manifest is named Fastq_mqnifest, so the command would look like this:

qiime tools import \
  --type 'SampleData[SequencesWithQuality]' \
  --input-path Fastq_mqnifest \
  --output-path demux-single-end.qza

Hi Matthew,
I resolved.
Thank you for your help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.