import Casava 1.8 single-end demultiplexed fastq¶

Hey all,
I am trying to import casava 1.8 demultiplex format.
the file are named:
C-N4B_S3_L001_R1_001.fastq
C-N4B_S3_L001_R2_001.fastq
BAD REQUEST - Missing one or more files for SingleLanePerSamplePairedEndFastqDirFmt: '.+_.+_L[0-9][0-9][0-9]_R[12]_001\.fastq\.gz'
I tried to rename the file as: C-N4B_03_L001_R1_001.fastq; C-N4B_03_L001_R2_001.fastq

no way...what is wrong PLEASEEEE

many thanks
Sofia

Dear Dr Keefe, sorry the question...I am trying to import my files as casava format but something is not working ...


I am trying to go on with my work!!!

many thanks
A

Welcome to the forum, @sofia!
Please do not send questions as private messages unless absolutely necessary - keeping them public helps the rest of community learn from the work you put into them.

Are you sure the data you're trying to import is actually in Casava format? Based on the regular expression in your error message, the Casava importer expects fastq.gz files, and your files are .fastq, but not .fastq.gz.

gzip, which produces that file extension, is a compression tool (like zip/unzip). Did you unzip the data files themselves unnecessarily before trying to import them?

If you're unsure which format of data you have, the importing tutorial gives a good overview of the various import formats. Asking your sequencing provider can be a good option too.

Happy :qiime2: -ing!
Chris

p.s. Just Chris is fine - no PhD here. :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.