ID's Not in Found Metadata

EDIT: I have just tried ‘feature-table filter-samples’ and ‘feature-table filter-seqs’ and they have worked. Currently attempting the 3 commands below with the new filtered input files, and hoping the error does not recur.

Hello there. I am using three different commands:

  • diversity core metric phylogenetic
  • diversity alpha rarefaction
  • taxa barplot

They all have an option of having an input metadata file. When running these commands with a metadata input, I receive errors that my IDs are in the table but not in the metadata. I can understand why, as I removed some unwanted samples in the original metadata after demultiplexing. With the 3 commands above, I was thinking that the metadata option would help filter out unwanted samples.

Besides manually removing/not demultiplexing unwanted samples, is there a method to filter them out when using the 3 commands above? I also want to run these commands with the metadata input, as the metadata contains variables/factors which I am interested in for analysis.

I hope my question makes sense. Thank you!


Hi @YinXun,
You can certainly remove those samples from your feature-table using the ID-based filtering. See an example in the tutorial here. It would be nice though if the extra samples from the feature-table were simply ignored.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.