I can't import my demultiplexed paired end files

Hello,

I have paired end demultiplexed files and I am using the following code:

qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path /gpfs_home/fastq --source-format CasavaOneEightSingleLanePerSampleDirFmt --output-path /gpfs_home/demux-paired-end.qza

My files looks like this

BB9_02_L001_R2_001.fastq
BB9_02_L001_R1_001.fastq

with a different made up barcode number for each pair. For example:

BB19_03_L001_R2_001.fastq
BB19_03_L001_R1_001.fastq

List goes on.

I’ve read the other responses to questions like this, but I can’t seem to figure out why I’m still getting the same error message.

ValueError: Missing one or more files for CasavaOneEightSingleLanePerSampleDirFmt: '.+_.+_L[0-9][0-9][0-9]_R[12]_001\\.fastq\\.gz'

Hi @Biancabrown! Thanks for the detailed post explaining your problem!

The issue here is that the CasavaOneEightSingleLanePerSampleDirFmt is expecting gzipped fastq files (e.g. foo.fastq.gz), but you are providing non-gzipped files (e.g. foo.fastq).

I think you have two options:

  • gzip all of your files (one-by-one) - we don’t have a utility for that, so you will need to consult your favorite search engine.
  • Use a Manifest format! This format is able to gzip unzipped files while importing. The downside here is you need to create a new file (the manifest), which can be tedious.

Good luck, and let us know if you get stuck! :t_rex:

1 Like

Hi @thermokarst

Thanks again, you hit the nail right on the head! This suggestion also worked well.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.