How to use deblur to qualify the sequences

Hi everyone,
I was used to work qiime1 and changed to the qiime2. I used the data for 10% subsample of Atacama soil microbiome and followed the pipeline following:

  1. qiime tools import --type EMPPairedEndSequences --input-path emp-paired-end-sequences --output-path emp-paired-end-sequences.qza
  2. qiime demux emp-paired --m-barcodes-file sample_metadata.tsv --m-barcodes-category BarcodeSequence --i-seqs emp-paired-end-sequences.qza --o-per-sample-sequences demux
  3. qiime quality-filter q-score --i-demux demux.qza --o-filtered-sequences demux-filtered.qza --o-filter-stats demux-filter-stats.qza
  4. qiime deblur denoise-16S --i-demultiplexed-seqs demux-filtered.qza --p-trim-length 140 --o-representative-sequences rep-seqs-deblur.qza --o-table table-deblur.qza --p-sample-stats --o-stats deblur-stats.qza

the error occurred:
Plugin error from deblur:
No sequences passed the filter. It is possible the trim_length (%d) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.

Debug info has been saved to /tmp/qiime2-q2cli-err-gg0931yk.log

I don’t know how to resolve the problem and look forward to your reply.
Thanks!

Hi @heavennew!

This error message suggests ensuring your trim_length is an appropriate value --- one way to investigate is to demux summarize your post-quality-filtered data (demux-filtered.qza). From the Moving Pictures tutorial:

In general, the Deblur developers recommend setting this value to a length where the median quality score begins to drop too low.

If that doesn't reveal anything, the next thing that error message suggests is ensuring that all adapter sequence is removed. You can check out q2-cutadapt for that!

If possible, can you share your demux summarize viz here? Thanks! :t_rex:

1 Like

Hi Thermokarst,
Thank you your reply. I upload the demux summarize file here.
I don't how to read the figure of quality score figure and how can I set that value.

demux-filter-stats.qza (8.8 KB)

Hi @heavennew - it looks like you attached the results from quality-filter q-score, instead of demux summarize - can you please attach the other file, too?

Looking at the stats you provided:

02 PM

According to this, you only have one sample, which only has two reads --- something went wrong here! We might need to start back at the import and demux steps to make sure things are working for you.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.