How to explain the table results after dada2 denoise-paired

Dear colleagues,
I have some doubts regarding the table generated after processing high-throughput data using DADA2. The above graph is my result. Here, I have one question: most unique sequences showed up in the "# of sample observed in" only 1. Why? That means each sequence is only retrieved from one sample? I believe the unique ASVs would not be detected in only one sample. Could anyone do me a favor and explain this problem?
The following is my code:
qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path pe-64-manifest_NY_endo.txt
--output-path paired-end-demux.qza
--input-format PairedEndFastqManifestPhred33V2

   qiime demux summarize \
    --i-data paired-end-demux.qza \
    --o-visualization demux.qzv 

   qiime dada2 denoise-paired \
   --i-demultiplexed-seqs paired-end-demux.qza \
   --p-trunc-len-f 245 \
   --p-trunc-len-r 245 \
   --o-table table.qza \
   --o-representative-sequences rep-seqs.qza \
   --o-denoising-stats denoising-stats.qza

   qiime metadata tabulate \
   --m-input-file denoising-stats.qza \
   --o-visualization denoising-stats.qzv

   qiime feature-table summarize \
   --i-table table.qza \
   --o-visualization table.qzv \
   --m-sample-metadata-file sample-metadata-NY-endo.txt

Good morning,

That's correct.

Yes, this is a problem. I had this problem when part of the barcodes was still inside my sequences. This led to identical ASVs being split into separate ASVs because the barcode was different.

I fixed it by trimming out the barcode. You can remove barcodes using cutadapt or the --p-trim-left-* settings in DADA2.

Let us know what you try next!

Dear colinbrislawn,
Thank you very much. It works well. I used the --p-trim-left-f and --p-trim-left-r to remove the barcode and got a good result.

Best wishes


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.