How to do multiplex of Ion torrent sequences

Hello Colin,
Thanks for your reply.
I checked the "fastq manifest format" and as I understood this command is not gonaa work with my datas. Yes, I have one fastq file per sample please see the attachment fastq.png"

" but I don't have forward and reverse sequences separately. Each fastq data has data like please see the attachment F8_fastq.png "". I was looking the Qiime2 tutorial and it seems like this tutorial is for illumina sequences and in my case I am using Ion Torrent PGM and output is not same like illumina. I dont have barcode.fastq file and I am not able to proceed further.

Kindly help me to solve this issue.

Thanks,
Sincerely,
Khemlal

Good morning Khemala,

Thanks for posting your files for me. I think this format will work for importing: Single End Fastq Manifest Phred33. This format only needs a forward sequences, which is a perfect fit for your data. So when the tutorial says reverse, you just don’t include those lines.

Yes, a lot of the qiime tutorials are about Illumina. We should write some tutorials for Ion Torrent data too. The good news is that after you import your data and error correct it, the rest of analysis is exactly the same.

Colin

Hello Colin,
Good Morning,
Thanks for your useful comments. I am sorry, I didn't explain properly in my previous post. Here in attachment "

" explains the outline of Ion Torrent PGM platform. So we get the merged FASTQ files from forward and reverse reads. In previous post's image ""
the name like V3-341F8.fastq etc. where "F8" or all other files like from "F8- F46".fastq are just barcode numbers to identify the files.
I hope now I made clear myself regarding my problem with Qiime2 to use the tutorial for Ion Torrent PGM platform based sequences. Kindly give your suggestion how to start the process.

Thanks,
Sincerely,
Khemlal

1 Like

Good morning Khemlal,

That’s a very helpful diagram! I’m not very familiar with the Ion Torrent PFM platform, but here is what I would try first.

  1. Build your manifest file and save it as se-33-manifest.csv. Maybe like this:
sample-id,absolute-filepath,direction
# Lines starting with '#' are ignored and can be used to create
# "comments" or even "comment out" entries
sample-8,$PWD/some/filepath/V3-341F8-.fastq,forward
sample-9,$PWD/some/filepath/V3-341F9-.fastq,forward
sample-10,$PWD/some/filepath/V3-341F10-.fastq,forward
...
more samples
...
sample-46,$PWD/some/filepath/V3-341F46-.fastq,forward
  1. Then import your reads:
qiime tools import \
  --type 'SampleData[SequencesWithQuality]' \
  --input-path se-33-manifest.csv \
  --output-path single-end-demux.qza \
  --source-format SingleEndFastqManifestPhred33

Let me know how well that process works. One key question for me is how the Ion Torrent goes about ‘merging’ the forward and reverse reads. This could change our demultiplexing strategy.

Colin

2 Likes

Thanks for that @colinbrislawn!

We probably want to import as type SampleData[JoinedSequencesWithQuality], instead:

qiime tools import \
 --type 'SampleData[JoinedSequencesWithQuality]' \
 --input-path se-33-manifest.csv \
 --output-path single-end-demux.qza \
 --source-format SingleEndFastqManifestPhred33

This will let QIIME 2 know that the reads are joined, instead of just single-end reads.

I am working with demultiplexed data from PGM Ion Torrent, like khemlalnirmalkar user, and I think that I understood how to import the data through the manifest file.csv (until my understanding a file with a list of all your fastq files paths.

In your example all reads are in forward in the column direction, however, the problem in PGM is that you can add the barcodes after the PCR, in which, the PCR product is ‘blundt ends’ so the barcodes can fixed in forward or reverse and you can have the reads in both directions in the same file, forward and reverse.
Is this a problem when you work with qiime?

The “direction” doesn’t necessarily matter in that manifest, so long as it is all one, or all the other (forward or reverse) when importing single-end reads. Since you have demultiplexed reads, go ahead and import them as single-end, then trim the barcodes using q2-cutadapt. You might need to set up a few parameters in that step in order to catch the barcodes in both directions. Let us know how that goes for you! :t_rex:

An off-topic reply has been split into a new topic: Help formatting FASTQ manifest file

Please keep replies on-topic in the future.

Thanks for your comments @thermokarst @colinbrislawn @MMC_northS . In the second figure from my previous post, files from V3-341F8 to V3-341F46.fastq are containing both forward and reverse sequences.
I am sorry but I am bit confused. Since i don’t have barcodes.fastq. file and I am worrying how to merge my all different sample .fastq file to create Biom file.
As we were doing in qiime1, the first fastq to fasta (fna) file then ,otus picking n biom file.

Thanks

Hi @khemlalnirmalkar -

If your reads are already demultiplexed, there is no need to worry about barcodes (just make sure they have been removed from your demultiplexed reads). Please see my post above about importing these demultiplexed reads.

Since these reads are already technically “joined”, you won’t be able to use q2-dada2 (since that plugin requires your reads be unjoined), and you are also not able to use q2-deblur, since that tool only works with Illumina products. That leaves you with OTU clustering as the only available method for generating a feature table.

I hope that helps - let us know if you have any questions. Thanks!

Hello Qiime2 users @Nicholas_Bokulich @thermokarst @colinbrislawn @MMC_northS
As per your suggestions, again tried to import my .fna files (demultiflexed) using

qiime tools import \ --input-path seqs.fna \ --output-path seqs.qza \ --type SampleData[Sequences]

for the next step but I could not do successfully. It asked two kind of files. one .fna files and second barcode.fastq file. And again I got stuck in the first step as Ion Torrent doesn’t provide barcode.fastq file.

@MMC_northS As you mentioned earlier, you are also working with Ion Torrent PGM, can you explain in detail, how did you process your .fastq files after sequencing?

Thanks,
Sincerely,
Khemlal

Hi @khemlalnirmalkar

I have imported in QIIME2 my fastq files from PGM using the next command line:
qiime tools import
–type ‘SampleData[SequencesWithQuality]’
–input-path manifest_file.csv
–output-path demux.qza
–source-format SingleEndFastqManifestPhred33

You have the instructions to make your manifest_file here: https://docs.qiime2.org/2018.2/tutorials/importing/ in the section “Fastq manifest formats”.

After import your data you can continue doing analyses in QIIME2 (filter quality, clustering, denoising, assign taxonomy, etc…). Other option is use other program like Cutadapt to filter by quality and length, etc.) and then import the fastq filtered instead the raw files.

I hope this information will be useful for you :slight_smile:
Good luck!
MMC

2 Likes

Hello @MMC_northS Thanks for your suggestion. I tried as you mentioned and got an error as in the attached picture.

while importing my raw sequences (fastq files), I used --type option with EMPSingleEndSequences, but couldn't able to convert them. I tried some more file type but same error came.
I suppose my manifest.csv was correct "attached image manifest.jpg manifest"

Kindly check and help me to correct my error.

Thanks,
Sincerely,
Khemlal

Hi @khemlalnirmalkar

the first thing different to my command that I can see is in the --type command.
I used: --type ‘SampleData[SequencesWithQuality]’
and you used EMPSingleEnd Sequences ; and you did not use any symbol like ‘[…]’

Regarding your manifest file I supposed is right but it depending on where you have your sequences.fastq located in your computer or server.

I copy one line of my mapping file for just in case you can compare with yours.
Sample1,$PWD/Fastq_for_QIIME2/Sample1.fastq,forward

I used the absolute path or my working directory in that moment.

I hope you fix your error!
Best,
MMC

2 off-topic replies have been split into a new topic: Metadata preparation and rarefaction level

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.