Help with filter_samples: "Error: no such option: --m-metadata-file"


(Nevin Cullen ) #1

Hi there,

I’m trying to create a new artifact that only contains my kit controls using the filter_samples command and from my code:

(qiime2-2018.11) cl2-wifi-10-215-16-22:PigeonSpleenNevin nevincullen$ qiime feature-table filter-samples
–i-table taxon-table-filtered.qza
–m-metadata-file PigeonSpleen-metadata.txt
–p-where “SampleType = ‘KitControl’”
–o-filtered-table table-taxa-filtered-ctrls-only.qza

I keep getting this error message:

“Error: no such option: --m-metadata-file PigeonSpleen-metadata.txt”

Any help on figuring this out would be greatly appreciated!


(Matthew Ryan Dillon) #2

Hey there @ncullen!

This means that there was no file called PigeonSpleen-metadata.txt in your working directory. Is that spelled correctly? Is that the right filepath?


(Nevin Cullen ) #3

I tried re-typing the file name, making a duplicate file with a different name and copying the name directly from the file and pasting it into the script, but none of those worked. I ended up opening the file in excel and saving it as a new tab delimited text file with a new name, and that seemed to work.


(Nicholas Bokulich) #4

mysterious. Perhaps there was a hidden file extension in the filename. You could drag and drop the file into your terminal to see what the file’s full name is.

but in any case I am glad to hear it’s working now!


(Matthew Ryan Dillon) #5

@ncullen — my guess is that the filename didn’t match exactly as typed, but when you saved a new copy of the file that ensured the right file is present.


(system) closed #6

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.