Gneiss table.qza

hello
I am trying to use gneiss using table.qza generated from DADA2 denoise but generated this error below.

The table.qza is different with the one generated from dada2 denoise?

thanks for you help

That looks like an outdated version, so you get the same error with the newest qiime2 version?

Hi Jamie

Thanks for your information. You were right. I was using old version. It worked after I updated my qiime2.

However, I have got a new problem now. I was running the following command and got a memory error. With the memory error, is there an alternative way to run the job, if I cannot really increase my memory?

thanks for your help

How many microbes are we talking about in your table? If you have say 100k microbes, that will result in a 100k x 100k table, which will blow memory on most machines. A quick way around this is to filter out microbes (i.e. excluding low abundance / sparse microbes).

Hi Jamie

Thanks for your information. This is the information from the table. DO you think I need to filter out the microbes? If so, how do you think I should filter it properly?

Thanks for your help and Merry Christmas
Bowen




Hmm - it is a little weird to hit memory limits with 10k microbes. How much RAM do you have?

There are a few singletons in that dataset – so I would recommend filtering out taxa that appear in less than ~5 samples. Note that this is a ball-park estimate, and this also depends on the number of covariates that you will run in your linear model. But since you have 15 samples – I wouldn’t run more than 1 covariate at a time.

Hi Jamie

Thanks for your reply. I have 12G RAM, do you think its enough to run this job? In your message, you recommended run 1 covariate at a time. If I am running the command below is it running 1 convariate or do I need to make other change. Sorry I am a bit confused.

qiime gneiss ilr-hierarchical **
–i-table collaborator2-table-w-remain-borderline.qza **
–i-tree collaborator2-hierarchy.qza **
–o-balances collaborator2-balances.qza &

12GB should be enough, but it looks like you will still need to perform some filtering.

RE the covariates - that is more for preparation for the next step when you run ols-regression. Your command performing the hierarchical clustering is fine.

Hi Jamie

Thanks for your time. I am not quite sure how should I filter my data for the next step. I was following the online tutorial to filter my data. Is there other steps that I should perform? Could you be more specific?

Hi @zhang_sonic,

I don’t think we necessarily cover this anywhere in a tutorial, but if you look at the help text for filter-features you’ll see a --p-min-samples parameter. If you were to use that you would be able to filter out features which appear in less than ~5 samples as @mortonjt suggests.

Otherwise, anything else you think is sensible (dropping low abundance features like singletons, etc) probably would help here as well. Combining multiple parameters will be treated as a “logical and” which means all parameters will be true for the final table.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.