Gneiss balances boxplot doesn't show up


When I try to view a taxa summary result from the qiime gneiss balance-taxonomy command the balance vs metadata category boxplot does not appear for a metadata category with three different levels. The boxplots show up for metadata categories with only two levels. I followed the same protocol to produce a taxa summary (i.e. y0_taxa_summary.qsv) for two different metadata categories, one with two levels and one with three levels. How can I view the boxplot for the metadata category with three levels? I tried opening the visualization on qiime view and in qiime studio and neither produce a boxplot.


Hi @rlm. Not sure if I completely understand the problem. Could you post your code along with the qzv files used to reproduce this problem?


This might be the problem @rlm spoke of. The metadata category: 'Patient' consists of five separate groups (AH, CR, DD, PS, ZC), while the metadata category 'Group' consists of two separate groups (AE or Rem).

Box and proportion plots are not generated when 'Patient' is specified, while they are generated when 'Group' is specified.

Here is sample code:

# metadata category: Patient (no box or proportion plot)
qiime gneiss balance-taxonomy \
    --i-table comp.qza \
    --i-tree hierarchy.qza \
    --i-taxonomy taxonomy.qza \
    --p-taxa-level 5 \
    --p-balance-name 'y0' \
    --m-metadata-file sample-metadata.tsv \
    --m-metadata-category Patient \
    --o-visualization y0_patient.qzv

# metadata category: Group (produces box and proportion plots)
qiime gneiss balance-taxonomy \
    --i-table comp.qza \
    --i-tree hierarchy.qza \
    --i-taxonomy taxonomy.qza \
    --p-taxa-level 5 \
    --p-balance-name 'y0' \
    --m-metadata-file sample-metadata.tsv \
    --m-metadata-category Group \
    --o-visualization y0_group.qzv

Here are the .qzv files:
y0_patient.qzv (75.0 KB)
y0_group.qzv (111.2 KB)

I am led to believe that differentially abundant OTUs or SV's can only be calculated using two groups. Therefore, box and proportion plots would not be generated when there are more than two groups. I suspect for the dataset above, I would need to compare two patients at a time, rather than five. But I am likely wrong? From this post, more than two groups are in the boxplot: Balance interpretation confusion

Hopefully, this information can clear up the problem.


Hi @kparke10

Right, the proportion plots will not show up if the metadata-category has more than 2 different groups.

However, the boxplots should always be generated if the metadata / metadata-category is specified correctly, even if there are more than 2 groups. The only time that this isn’t displayed is if the metadata file wasn’t found, or if the metadata category is incorrect.

Could you post the metadata-file just to sanity check this?

Yes. This is the same problem I identified. I do remember visualizing boxplots with more than two groups in the past. Maybe the option was disabled in a recent update?

Here are a few files to reproduce the issue.

composition.qza (56.3 KB)
hierarchy.qza (51.0 KB)
taxa.qza (51.1 KB)
metadata.tsv (1.1 KB)
y0_taxa_summary.qzv (80.7 KB)

qiime gneiss balance-taxonomy \
    --i-table composition.qza \
    --i-tree hierarchy.qza \
    --i-taxonomy taxa.qza \
    --p-taxa-level 2 \
    --p-balance-name 'y0' \
    --m-metadata-file metadata.tsv \
    --m-metadata-category Patient \
    --o-visualization y0_taxa_summary.qzv
1 Like

qiime gneiss balance-taxonomy
--i-table composition_pruned.qza
--i-tree hierarchy_pruned.qza
--i-taxonomy taxa.qza
--p-taxa-level 6
--p-balance-name 'y0'
--m-metadata-file map.tsv
--m-metadata-category nutrient
--o-visualization y5_nut_pruned_taxa_summary.qzv

I ran this command on the recent release of version 12. The .qzv file still does not produce a boxplot.

y5_nut_pruned_taxa_summary.qzv (37.0 KB)

map.tsv (2.7 KB)

Ok. Found the problem. Looks like there is a bug that where the plot isn’t being saved if there are multiple categories. This was introduced when incorporating proportions plots.

Just raised an issue here and am pushing a bug fix in a few minutes.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

QIIME 2 2018.2 is out now, and includes the bug fix @mortonjt put together for this thread. Thanks @mortonjt! :balloon: