Getting error when performing "diversity core-metrics-phylogenetic"

Hey there, I seem to get some python related error when I perform the following command. Any idea what can be the problem? I tried reinstalling qiime2 cleaning it from conda envs, without success, I get the same error only at this step. Any idea what is going wrong?

(I installed miniconda2, qiime2-2017.9 , Using Ubuntu 14.04)

(qiime2-2017.9) [email protected]:~/miniconda2/QIIME2/Amegut$ qiime diversity core-metrics-phylogenetic \
--i-phylogeny rooted-tree.qza \
--i-table table.qzv \
--p-sampling-depth 5000 \
--output-dir core-metrics-results

Traceback (most recent call last):
  File "/home/julian/miniconda2/envs/qiime2-2017.9/bin/qiime", line 6, in <module>
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/click/", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/click/", line 697, in main
    rv = self.invoke(ctx)
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/click/", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/click/", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/q2cli/", line 185, in __call__
    arguments, missing_in, verbose, quiet = self.handle_in_params(kwargs)
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/q2cli/", line 257, in handle_in_params
    kwargs, fallback=cmd_fallback
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/q2cli/", line 302, in get_value
    return qiime2.Artifact.load(path)
  File "/home/julian/miniconda2/envs/qiime2-2017.9/lib/python3.5/site-packages/qiime2/sdk/", line 78, in load
TypeError: Attempting to load Visualization with `Artifact.load`. Use `Visualization.load` instead.

Hey @jgarneau,

Wow, that error message is super confusing. I’ve created an issue to clean that up.

Fortunately, what’s wrong is very simple to fix! You’ve passed in a visualization to --i-table (table.qzv; intended for human consumption) instead of an artifact (table.qza; intended for machine consumption).



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

This error has been cleaned up in QIIME 2 2018.2! Now the error will explain that it expected an artifact instead of a visualization.