Feature sequences error


I am working with a biom table (generated in Q1) that I successfully converted into a .qza file and then I successfully spilt by project type. At this point I have a viewable .qzv file from the qiime feature-table summarize command but I cannot tabulate the sequences (qiime feature-table tabulate-seqs --i-data XXXXX.qza --o-visualization XXXXX.qzv)–the error message I receive is ‘Error: no such option: --i-data’

Thanks for any help

Hi @Sibyl_Bucheli we need a bit more information before we can assist you. Can you please provide the following information:

  1. What version of QIIME 2 are you using?
  2. What is the exact command or commands that you are trying to run?
  3. What is the full error produced when running this/these command(s)? Please provide either the output when running your command with the --verbose flag, or alternatively, please attach the log file that is referenced at the bottom of the error message (when run with --verbose).

At first glance it looks like you might’ve had a typo somewhere in the actual command you ran (I suspect the command sample you provided above was edited prior to posting, since you replaced the filenames with placeholders).


Hi @thermokarst,

I started in qiime1 to split libraries, assign OTUs, quality filter, and then combine the data from 4 different Illumina runs into a single biom table. Then in qime2-2017.7, I imported the biom table, converted it to a .qza artifact, then removed a smaller subset of data. Here is where I am stuck. My feature table shows data but I cannot generate an artifact with the actual sequences highlighted to blast as in the tutorials.

I am including now my notes with the the commends entered and the outputs produced. This includes the commands from qiime1 and qiime2. Also uploaded are the feature table artifact and .qza and visualization.

Thank you.

bucheli notes and output from qiime1 and qiime2.txt (19.5 KB)
fly-filtered-table.qza (875.9 KB)
fly-filtered-table.qzv (628.1 KB)

Hi @Sibyl_Bucheli:

Just took a quick scan of your notes TXT file, and the last couple of commands jumped out at me:

(qiime2-2017.7) l136008:fly-data shsu$ qiime feature-table summarize --i-table /Users/shsu/raw_files_2/combined-data/fly-data/fly-filtered-table.qza --o-visualization fly-filtered-table.qzv --m-sample-metadata-file /Users/shsu/raw_files_2/combined-data/fly-data/fly-mapping-file.tsv qiime feature-table tabulate-seqs --i-data /Users/shsu/raw_files_2/combined-data/fly-data/fly-filtered-table.qza --o-visualization rep-seqs.qzv
Error: no such option: --i-data

I noticed two things here

  1. Two separate qiime commands are squished together into one statement. Your terminal won’t know what to do with that, so we should split this into two commands. This is why you are seeing the error Error: no such option: --i-data — that flag is being passed into summarize, instead of tabulate-seqs.
  2. The input you are specifying for tabulate-seqs is of the wrong type (fly-filtered-table.qza is type FeatureTable[Frequency]), but that --i-data input requires type FeatureData[Sequence]. You will want to import your rep seqs to provide as input data, instead of your feature table.

Rewritten (I stuck some line breaks in here for presentation purposes, and the filepaths aren’t necessarily accurate):

########## Feature Table ##########
# Import feature table
$ qiime tools import \
  --input-path merged-otu-table.biom \
  --type "FeatureTable[Frequency]" \
  --source-format BIOMV210Format \ 
  --output-path merged-otu-table.qza

# Filter feature table
$ qiime feature-table filter-samples \
  --i-table merged-otu-table.qza \
  --m-metadata-file merged-mapping-V2.tsv \
  --p-where "ProjectType='fly'" \
  --o-filtered-table fly-filtered-table.qza

# Summarize feature table
$ qiime feature-table summarize \
  --i-table fly-filtered-table.qza \
  --o-visualization fly-filtered-table.qzv \
  --m-sample-metadata-file fly-mapping-file.tsv

########## Feature Data of Sequences ##########
# Import rep seqs
$ qiime tools import \
  --input-path rep-seqs.fna \
  --output-path rep-seqs.qza \
  --type "FeatureData[Sequence]"

$ qiime feature-table tabulate-seqs \
  --i-data rep-seqs.qza \
  --o-visualization rep-seqs.qzv

Hope that helps — feel free to follow up if you get stuck! Thanks!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.