Feature IDs not matching taxonomy

I am running into issues in taxonomic classification. I have followed the tutorial on this site (Overview of QIIME 2 Plugin Workflows — QIIME 2 2023.9.1 documentation) to filter, cluster and train a classifier as follows:

##Check and exclude chimeric and 'borderline chimeric' sequences.
qiime vsearch uchime-denovo --i-table table.qza --i-sequences rep-seqs.qza --output-dir uchime-dn-out

#Filter input tables and sequences
qiime feature-table filter-features --i-table table.qza --m-metadata-file uchime-dn-out/nonchimeras.qza --o-filtered-table table-nonchimeric.qza

qiime feature-table filter-seqs --i-data rep-seqs.qza --m-metadata-file uchime-dn-out/nonchimeras.qza --o-filtered-data rep-seqs-nonchimeric.qza

##closed reference clustering
qiime vsearch cluster-features-closed-reference --i-table table-nonchimeric.qza --i-sequences rep-seqs-nonchimeric.qza --i-reference-sequences silva-138.1-ssu-nr99-seqs.qza --p-perc-identity 0.97 --o-clustered-table otu_cr_table.qza --o-clustered-sequences rep-seqs-cr-97.qza --o-unmatched-sequences unmatched-cr-97.qza

**##**Extract the target region using the primers used for V3V4 in the sequencing
qiime feature-classifier extract-reads --i-sequences silva-138.1-ssu-nr99-seqs.qza --p-f-primer CCTACGGGNGGCWGCAG --p-r-primer GACTACHVGGGTATCTAATCC --p-read-orientation 'forward' --o-reads my_V3V4_SILVA138_97.qza

### Train the Naive Bayes classifier
qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads my_V3V4_SILVA138_97.qza --i-reference-taxonomy silva-138.1-ssu-nr99-tax.qza --o-classifier my_V3V4_SILVA-classifier.qza

##SILVA classification
qiime feature-classifier classify-sklearn --i-classifier my_V3V4_SILVA-classifier.qza --i-reads /rep-seqs-cr-97.qza --o-classification taxonomy-cr-97.qza

#Use the resulting table from the above viewed table to obtain the list of taxa IDs. Remove taxa IDs identified as contaminants. Also filter out Chloroplast, Unassigned and Archaea as these are technically not Bacteria.

qiime feature-table filter-features --i-table table-nonchimeric.qza --m-metadata-file cr_exclude.tsv --p-exclude-ids True --o-filtered-table table-cr-nonchimeric-nocontaminants.qza

The error comes, however, when I run the taxa plot command:
##Taxa plots

qiime taxa barplot --i-table table-cr-nonchimeric-nocontaminants.qza --i-taxonomy taxonomy-cr-97.qza --m-metadata-file metadata.tsv --o-visualization taxa-bar-plots-cr.qzv

Plugin error from taxa:

Feature IDs found in the table are missing from the taxonomy: {'b4f326142ef3c4b4f5418cf60b88d323', '11772f6a0e54e96ae72d57cb1abb4488',...)

I am not sure where I am getting it wrong. I will be very grateful if I can get help in solving this.


Based on your last commands, you are trying to create taxonomy barplot using unclustered table (ASVs), while your taxonomy annotations based on clustered rep-seqs (OTUs).
You should either classify unclustered sequences to use unclustered table or use clustered table and taxonomy of clustered sequences.


1 Like

It is indeed true that a problem shared is half solved. Thank you @timanix . I have looked through the script several times and didn't notice that. I am correcting that, and I believe it should work fine afterwards.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.