Feature Classifier killed

The process keeps getting killed when I enter this command: qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads ref-seqs.qza --i-reference-taxonomy ref-taxonomy.qza --o-classifier classifier.qza
This is the explanation that I get:

/apps/x86_64/singularity-imgs/qiime2/2018.6/qiime: line 3: 77272 Killed
singularity run -B $PWD:/data --pwd /data /apps/x86_64/singularity-imgs/qiime2/2018.6/qiime-2018-6.simg qiime "[email protected]"

Would anyone have any insight? Thanks for any help!

jeff

Hello Jeff,

Looks like you are running this out of a Singularity container. I’m not super familiar with this container architecture, but I bet it produces extra log files whenever it kills off a run. Could you post any log files or error it recorded so that we can look for clues? :mag: :male_detective:

Colin

Thanks Colin. I can’t find any log file unless it is somewhere I haven’t looked!

I did try this with the 90% identity reference sequences from the Silva 132 data set and it worked fine. This is the 99% and this is as far as I can get. Unless I can get a classifier trained on the 16s rRNA v34 region then I can bypass this step!

Is this possibly a Linux version issue?

Thanks again,

jeff

I don’t think so — I think @colinbrislawn was on to something with the singularity container observation. My guess is that there is some resource allocation limit specific to singularity — when running with the full SILVA dataset you are exceeding those limits (probably memory, if I had to guess). I would chat with your sysadmin to see what you can do to request additional resources, if possible. Otherwise, there are many posts floating around the forum discussing some potential strategies for reducing memory consumption when training.

Thanks! :t_rex: :qiime2:

I had been working with the system admin for the last few days in regards to this issue and they were not quite sure what the issue was. Nonetheless, I ran the command again yesterday and low and behold, it worked! The 5th attempt was the charm, apparently.

2 Likes

I chuckled at that.

Thanks for following up!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.