Feature-Classifier Help

Hello QIIME Community!

My colleague and I have been trying to classify our microbiome data for about two weeks now. I’m currently using Virtual Machine on my HP AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 2.00Ghx RAM 8.0, changed my VM settings for 7 CPU.

We have tried training a classifier from Silva database and Greengenes. I’ve also tried the pre-trained classifiers as well and we are getting the same error msg: MEMORY ERROR. I have adjusted chunk size and reads per batch, respectively. We are officially stuck.

I’m not sure what else I can do? Any advice welcomed!

Thanks in advance!
Kaylee

Hi! Did you try a new version Qiime2-2019.4? They optimized memory usage. Use only one thread and decrease amount of reads per batch if the problem reappear.
BTW, 8 Gb is not much, if it will fail again, you should consider running it on more powerful machine

1 Like

If you have still the common problem, you need to do them beside the previous comment:

  1. hire a RAM from the Amazon
  2. use a server or powerful machine
  3. try the parameter '--p-n-jobs' OR eve '--p-reads-per-batch'. Look it up in the relevant page in plugins.
  4. just make a wish in Christmas.:pray:
2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.