Feature classifier error

We are getting the following error message when we run the feature-classifier classify-sklearn step with the pre trained qualifier gg-13-8-99-515-806-nb-classifier.qza that we downloaded yesterday.

The scikit-learn version (0.18.2) used to generate this artifact does not match the current version of scikit-learn installed (0.19.1). Please retrain your classifier for your current deployment to prevent data-corruption errors.

I looked into the previous discussions here in this topic but couldn’t fix the problem. Can up please help us?

Somehow you downloaded an old version of this file (looks like this is at least 6 months old). Please check out the current docs to download the latest and greatest version of the pretrained classifier.

https://docs.qiime2.org/2018.2/data-resources/#taxonomy-classifiers-for-use-with-q2-feature-classifier

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.